Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem installing gnome-shell. When I run sudo apt-get install gnome-shell, it says:

gnome-shell : Depends: libgnome-keyring0 (>= 3.2.2-2~) but 3.2.0-0ubuntu1 is to be installed
Depends: libtelepathy-glib0 (>= 0.15.6) but 0.15.5-1ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

I tried to find libgnome-keyring0 in synaptic, but it says that I already have the latest version. Please help.

P.S. I don't really need gnome-shell, I just need gnome-tweak-tool, which is gnome-shell dependent.

share|improve this question
add comment

1 Answer 1

(This is assuming you are using Unity)

gnome-tweak-tool Isn't gnome-shell dependent as far as I know, you should be able to install it with sudo apt-get install gnome-tweak-tool. That said, it may be suffering from the same issues as gnome-shell.

Personally, I'd recommend you use ubuntu-tweak. It provides the same options as gnome-tweak-tool, as well as several others such as a janitor, etc. You can install it with

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update && sudo apt-get install ubuntu-tweak
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.