Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title suggests I'm a new to linux and I'm having some trouble setting up it up. I have a DELL inspiron n5110 with an nVidia 525m and i7-2630QM. Well after a bit of reading and confusing myself I followed instructions in this tutorial, which seemed to work. The battery usage dropped from ~2000 to ~1600. Thou it's not as much as I'd like to. So I tried the Intel tweaks.

After applying the Intel tweaks it didn't take any effect, I think I did something wrong. Thou I'm not sure. But the comments stated that most people saw a drop to ~1000. I wanted to try just disabled the card on boot with the instructions here: http://github.com/Bumblebee-Project/bbswitch, but I can't open /etc/modules trough the terminal. It says "Permission denied" or "Command not found" if I use sudo /etc/modules. I'm not sure what other info do you need to be able to make any sense of this. So just ask and tell you what I can. I'd need to achieve a much lower usage one way or another, because I need to the laptop in class.

share|improve this question
    
I don't have an nvidia optimus card, but try this: askubuntu.com/questions/36930/… –  medigeek Feb 12 '12 at 10:03

1 Answer 1

Bumblebee installation instructions can also be found in How well do laptops with Nvidia Optimus work?

It includes bbswitch by default, so you do not have to get the code from the Git repository nor edit /etc/modules (it's a file, not a command/program!) because the card is disabled when Bumblebee starts. Keep in mind that the power usage depends on the machine your have. For example, I have a GT425M GPU with an i5-460M CPU. That'll use way less power than an i7 processor. To improve battery life:

  • Lower the brightness level of the screen
  • Disable wireless if you are only taking notes or reading PDFs in class and do not need to use Internet
  • Disable the webcam (Fn + ??) and other unnecessary peripherals like Bluetooth
  • Apply the Intel module options as mentioned in Battery life decreased after upgrade to 11.04
share|improve this answer
1  
Of course i disabled Bluetooth and WiFi, but even so i only get about 40% of the Batterylife id get under Windows under the same conditions. I'll try the link you sent me, I'm also wondering could i run something like this in ubuntu? link –  Infernal Feb 12 '12 at 13:44
    
On a side note. When type "sudo gedit /etc/default/grub" to add the i915.i915_enable_rc6=1 it opens a text editor, but it also shows an error. (gedit:1966): Gtk-WARNING **: Attempting to store changes into /root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.9RTP9V': No such file or directory (gedit:1966): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory When i save the file, i get exactly the same error. After which the terminal freezes. –  Infernal Feb 12 '12 at 15:28
1  
Thank you very much! I got it sorted with a fresh install of Ubuntu. –  Infernal Feb 13 '12 at 7:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.