Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So, this is my problem:

I was able to install Ubuntu 11.10 in dual boot in my MacBook Pro 5.1 with rEFIt. I had to do it twice because first time I installed GRUB in /sda instad of in /sda3. Anyways, it wouldn't work: after choosing Ubuntu in rEFIt I got the balck screen with the white cursor.

Someone told me to try with an earlier version, so I installed Ubuntu 10.10. It works fine, but when I update to 11.04 I get the same problem: it won't boot Ubuntu anymore.

Any idea of what can I do to update Ubuntu? It looks like a problem with GRUB but I don't know how to fix it.


share|improve this question
up vote 1 down vote accepted

If you update to version it 11.04 you will not succeed because each older Ubuntu can only be updated to the latest version and it is now 11.10. If you took a lot programs and plugins, go to and download version of 11.04 (by the official Ubuntu site you can download the upcoming (12.04), current (11.10) or a previous version (11.04)). This is made through Mac OSX because you would rather install Ubuntu 11.04 installer ask if you delete Ubuntu 10.10 (on a single computer can have only one Ubuntu). I would recommend you still can download Ubuntu 11.10, so you dial between 11.04 and Ubuntu Ubuntu 11.10.

share|improve this answer
Sorry, I don't understand. You are saying that since I'm running Ubuntu 10.10 I can't update the common way, rigth? So i have to download the intall cd of Ubuntu 11.10, then boot into my Ubuntu 10.10 Ubuntu and install it? Or do I have to download first 11.04? What do I do when it asks me about GRUB? – aderojas Feb 12 '12 at 16:00
NVM I was able to update now – aderojas Feb 13 '12 at 19:12

I suspect you did not use rEFIt to fix the partition table after installing Ubuntu. Look at the section "Fix the partition tables" section of this help page.

share|improve this answer
Actually I followed those instructions. After installing Ubuntu 11.10 I tried to fix the tables with rEFIt, but it didn't let me. I tried fixing the tables by booting into the LiveCD and downloading gsync, but I wasn't able to save gsync in mnt/root, so I couldn't do it. Any ideas of how to fix the tables? Thanks! – aderojas Feb 12 '12 at 16:05
Ok. Don't bother with the LiveCD. Go into OS X and use the terminal to follow the directions in post #185. That worked for me, so hopefully it will work for you. – Chan-Ho Suh Feb 12 '12 at 18:18
I actually tied that too, but it seemed to not recognize I had installed gdisk. Right now ubuntu 11.10 is working, I just have the problem that rEFIt shows 2 Linux icons. Not a big deal, although if you now how to fix it I would really appreciate ;) – aderojas Feb 13 '12 at 3:27
That's strange you were not able to run gdisk... What happens if you try booting off the other "Linux" partition? Also, you mentioned above that this other Linux partition is on "HD", does that mean "Macintosh HD"? Do you also have an Apple icon to boot into OS X? Also, it would be helpful to go into Disk Utility in OS X and see the list of partitions (their file system types and size). This will help you fix the partition tables (which is probably what you need to do anyway to fix this issue). – Chan-Ho Suh Feb 13 '12 at 5:36
I have 3 icons: Apple from HD, Linux from HD and Linux from Partition 3. Both Linux icons work fine and log into the same system (user, folders, everything the same). When I run the list of partitions that's what I see, although I'll check again. Thanks! – aderojas Feb 13 '12 at 16:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.