Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using my phone to connect to the Internet the default mobile broadband option wont support my nokia phone(x2-01) so i am using wvdial but when using wvdial install button in software centre is in disabled mode (but install option in menu still works) but it is not convenient to use same is the case with ubuntu one

share|improve this question
    
Easy workaround: Install the packages you need from the command line. –  tumbleweed Mar 26 '12 at 10:36
    
command line and synaptic have no problem ,but software centre is more user friendly –  Tachyons Mar 26 '12 at 11:29
    
Yes, and this sounds like a software centre bug. It only knowns about connections brought up by network manager. It should probably have a way of overriding that, like Firefox does. –  tumbleweed Mar 26 '12 at 12:05
    
Is there any manual way to enable that button? Can i enable it through gconf-editor or dconf editor? –  Tachyons Mar 26 '12 at 12:26
add comment

3 Answers

up vote 3 down vote accepted

You can simply stop the Network Manger and everything will run great including Ubuntu Software Center! stop it by run this commend in the terminal:

sudo stop network-manager

you can bring it back by restart your computer or simply run this:

sudo start network-manager
share|improve this answer
    
Thank you , It works :-) –  Tachyons Jul 14 '12 at 11:02
add comment

As mentionned in the comments, you can install wvdial in Synaptic or via command line, paste the following in the terminal: sudo apt-get install wvdial. You could also upgrade to Ubuntu 12.04 (though now in beta 2 at the time of writing, but that's Precise's last pre-release build). Installs flawlessly via the Ubuntu Software Center in Ubuntu 12.04. Another option would be to use the Lubuntu software centre or Mint software centre (for the Mint software center try getting it from the Mint repositories), there's also the Linux Deepin software center made originally for a Chinese spin on Ubuntu. Needless to say you have many options, and I always tried avoiding the Ubuntu Software Center in Ubuntu 11.10 considering how slow it was, a whole seven seconds to load on my SSD! Gconf editor is retired in the recent versions of Ubuntu. AFAIK dconf has no control over the Software Center's limitations, or even app-specific limitations (including bugs) for that matter.

share|improve this answer
add comment

I have a similar problem using Software Center and Update Manager in Ubuntu 12.04.2. Same thing, Software Center does not recognize my wifi connection with wicd. When I click on Install for packages, nothing happens. Update Manager will check for and download updates, but it still says "you may not be able to check for or download updates" (or something to that effect).

So just for kicks, I tried;

sudo stop network-manager

and the weird thing is it worked!

It's weird, because I removed network-manager-gnome right after I installed wicd. I thought that network-manager was gone, did I just remove the gui? Do I still need network-manager at all since I have wicd?

If not how can I really remove it without breaking my networking? The first time around, I removed it with the Software Center, and it still shows it as not installed there.

ps Thanks for the solution above, I never would have thought to try it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.