Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed fastdebug build of JDK 6 (Linux x64 version, since there is no Ubuntu specific build) in /usr/lib/jvm directory, manually set during installation process. Installation completed successfully (at least such a message was showed at the end). Now I have /usr/lib/jvm/jdk.1.6.0_25/fastdebug/bin folder.

I ran this command to install (if it matters):

sudo java -jar jdk-6u25-ea-bin-b03-linux-amd64-debug-27_feb_2011.jar

When I run:

sudo update-alternatives --config java

I see all my JVMs (open jdk, sun, etc.) but there is no fastdebug build in the list to choose. I also ran the following:

sudo update-java-alternatives --jre -s jdk1.6.0_25

But it says:

"directory does not exist: /usr/lib/jvm/jdk.1.6.0_25"

Why so? The directory does exist! how to add this jdk to the list? I have the same problem with IBM's jdk. I also can't add it to the alternatives to select for the same reason ("directory does not exist..."). What did I do wrong?

PS. according to the information on the site, all files are made in fastdebug/bin and fastdebug/jre/bin directories executable using chmod command.

share|improve this question

closed as too localized by James Dec 31 '12 at 2:27

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

@Gigili: thaks for editing, but there is no Ubuntu 11.10 specific download, there is general linux version... so I do not understand your edit at this place... – Maxym Feb 11 '12 at 22:48
That's what you said: " I use Ubuntu 11.10" – Gigili Feb 11 '12 at 22:50
Anyway, you can rollback the edit if you disagree. – Gigili Feb 11 '12 at 23:03
guys, is it a problem without solution?? – Maxym Feb 13 '12 at 10:40
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. – Eliah Kagan Dec 30 '12 at 3:58

look for jdk 1.6.0_25 ... that's the required development kit. then install it 'em not sure but try here

share|improve this answer
@Mitch That's a download link, so what you've said isn't quite applicable. I don't think it is (or ever was) the best download link for this, though. – Eliah Kagan Aug 26 '12 at 19:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.