Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I change the default session for when using auto-logins?

Every time I restart my computer it auto-logs me into the Unity desktop, is there some way to make Gnome the default choice, I hate having to log out every time and switch to it.

share|improve this question
    
Your preferred desktop should be remembered automatically. If it doesn't, it's a bug. Report it on Launchpad.net. In the future, please try to provide information about what version of Ubuntu you're using. It makes things easier. –  Jo-Erlend Schinstad Feb 11 '12 at 19:10
    
Disable auto login, then choose to log into the Gnome session upon reboot, Gnome will be the default as it was your previous session. –  Uri Herrera Feb 11 '12 at 19:11
add comment

marked as duplicate by Bruno Pereira, Takkat, jokerdino, fossfreedom, Octavian Damiean Feb 13 '12 at 17:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

To make Ubuntu 11.10 auto log-in gnome-shell, open up a terminal window and run this command:

sudo /usr/lib/lightdm/lightdm-set-defaults -s gnome-shell

If you want to change back to Unity, run:

sudo /usr/lib/lightdm/lightdm-set-defaults -s ubuntu
share|improve this answer
add comment

gksu gedit /etc/lightdm/lightdm.conf and you will see something similar to

[SeatDefaults]
user-session=xubuntu

just change the session and save

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.