Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to mount zfs snapshot. It should to be so easy...but I can't do that. I'm using Ubuntu Server 11.10 Oneric, kernel 3.0.0-15-server.

Installed ZFS from ppa also I'm using zfs-auto-snapshot. With manually created snapshots the same situations.

How to mount zfs snapshot?

root@us1:/# zfs list -t snapshot
NAME                                                            USED  AVAIL  REFER  MOUNTPOINT
tank/www@zfs-auto-snap_hourly-2012-02-11-1917                   0      -   268K  -

root@us1:/# zfs mount tank/www@zfs-auto-snap_hourly-2012-02-11-1917 /mnt/snapshot/tank/www
too many arguments
usage:
        mount
        mount [-vO] [-o opts] <-a | filesystem>

For the property list, run: zfs set|get

For the delegated permission list, run: zfs allow|unallow

root@us1:/# zfs mount tank/www@zfs-auto-snap_hourly-2012-02-11-1917
cannot open 'tank/www@zfs-auto-snap_hourly-2012-02-11-1917': operation not applicable to datasets of this type
share|improve this question

1 Answer 1

up vote 4 down vote accepted

Running ZoL, just use the regular mount command like this:

mount -t zfs tank/www@zfs-auto-snap_hourly-2012-02-11-1917 /mnt/snapshot/tank/www

Dismount it like this:

umount /mnt/snapshot/tank/www

This is a bug that is being tracked at https://github.com/zfsonlinux/zfs/issues/173

share|improve this answer
    
Thanks. You are right. I didn't tried regular "mount". –  BBK Feb 13 '12 at 18:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.