Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed KDE, and every time I run the Software Updates program it says:

This operation cannot continue since proper authorization was not provided.

How can I get it to work?

share|improve this question
    
Do you have kdesudo or kdesu installed? –  devius Feb 11 '12 at 17:10
    
KDE Software Updates use PolicyKit, not kdesudo –  Lekensteyn Feb 11 '12 at 17:40
    
Can we get a few more details? When does this error occur? After opening, after checking for updates, after telling them to install? Maybe a screenshot? –  Huckle Feb 11 '12 at 18:02
    
Sorry about the misleading comment then. It's been a while since I used KDE. Then it's probably a PolicyKit policy problem. If that hasn't changed, policies can be edit in System Settings. –  devius Feb 11 '12 at 18:02
add comment

2 Answers

up vote 2 down vote accepted

Earlier : Ubuntu 11.10 with KDE installed does not prompt for elevation for privileged ops in all apps

Few bug reports:

Do you have the polkit-kde-1 installed ?

The polkit-kde-1:

PolicyKit-Kde provides a D-Bus session bus service that is used to bring up authentication dialogs used for obtaining privileges.

share|improve this answer
    
Thanks. sudo apt-get install polkit-kde-1 and rebooting fixed it. –  Jon Feb 13 '12 at 18:26
    
I have added that package note to the KDE installing section on the wiki help.ubuntu.com/community/InstallingKDE as it needs it so we need to note it. –  Liam Dawe Jul 31 '13 at 10:27
add comment

sudo apt-get install polkit-kde-1

did not fix it for me (Kubuntu 12.10), but this did:

sudo apt-get -f install

It also showed that I had a bunch of packages with unmet dependencies. I had just run a bunch of updates with Muon and rebooted, but apparently it did not pick up all the dependencies.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.