Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Environment: Ubuntu 11.10 / 12.04 with Classic Gnome Situation: Choose Nautilus of specific location Problem: It looks like Nautilus is opening 2 windows. After a while the second one dies.

Question: Why and how to prevent that problem?

share|improve this question

closed as off topic by Marco Ceppi Feb 11 '12 at 22:05

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

What to do with questions that describe known bugs? this has been reported on Gnome Bugzilla and as such is now closed. – Marco Ceppi Feb 11 '12 at 22:05
Why is this question closed? The bug report exists, but it doesn't contain a solution (or workaround) which answer(s) to this question give. – Mladen Jablanović Oct 1 '12 at 11:47

2 Answers 2

up vote 1 down vote accepted

If you wish to stop this behavior pending a gnome bug fix you may try this, tested on 12.04

sudo -H gedit /usr/share/applications/nautilus.desktop

Look for this line StartupNotify=true, change it to StartupNotify=false

Then restart nautilus or simply do a log out/in

There are 2 other nautilus .desktop's, home-folder.desktop & nautilus-folder-handler.desktop, I believe you can leave them as is

share|improve this answer
The use of gksu;gksudo is not needed when using a sudo gedit, it actually also opens the pita "untitled Document". There is no documentation that using sudo gedit is a problem. If concerned then sudo -H gedit is a better option than gksu – doug Feb 11 '12 at 20:46
My comment about the use of sudo gedit is only for 12.04 & earlier. For 14.04 & later it is not advised anymore, use gksudo gedit or sudo -H gedit – doug Jan 30 at 14:06

In general, if you start an app in GNOME Fallback mode, the window list button first displays 'Opening App' which then changes to 'App' after the application has started. This is to indicate startup. Not so with Nautilus. When it starts the 'Opening $LOCATION' message is displayed on another window list button.


Btw. I have reported an upstream bug which has been ignored since 201111:

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.