Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have switched my Macbook Pro 5.1 over to Ubuntu, because OS X Lion was dragging its heels on the 2.5-year-old hardware (sickeningly short old-hardware-support half-life... grrr)

Anyway, most of ubuntu is up and happy fine, but I want to be able to multitouch swipe my way around workspaces like you can in OS X.

Now I know that ubuntu is detecting the three-finger swipe (and indeed differentiating a 4-finger one) because it's configured to move the windows around the screen with that particular gesture.

So, how do I hook into that event, the three finger swipe, and reassign the action to moving workspaces?

EDIT:

So, trying Alexandre's suggestion below, I've now got a problem with touchegg.

I've tried putting in a new section in xorg.conf as suggested here (following instructions for the MBP 7.1,) but that makes this significantly worse - the clever velocity scaling goes, and the trackpad is far too responsive when just moving the cursor. The developer only provides documentation for 10.10 and 11.04, and the latter is supposed to be fully working and "automatic" - these were the instructions for 10.10.

In addition I've noticed, by running touchegg in the shell instead of a startup daemon, that it only detects 2-finger motion (both with and without the xorg hack) no higher multitouch gestures.

This is all very puzzling because, as I said, three finger gestures work, with a compiz animation (moving a non-maximised window). I guess it can't be a missing kernel module or something, since it works sometimes, so could compiz be swallowing all the events? If so, how would I test?

EDIT2:

I've tested unity 2D vs 3D (which seems to be how you disable compiz) and partial success. With compiz disabled touchegg can see all the multitouch events of the rainbow. However, it can't seem to run anything other than the "Nautilus Drag Window" event with the three finger gesture - this implies to me that nautilus is hooking into this event a bit too low down for me to get at!

I'm marking Alexandre's answer correct, since touchegg is one way to do this within the scope of the original question. I may post a more specific question later when I've figured out how to get this working exactly as I want!

share|improve this question
    
Thanks Alexandre - As yet I can't get this working. All it does is break my existing natural scrolling hack, and no response to any gestures. I'll investigate the developers tips for configuring it to detect the multitouch stuff at all, and post any more tips I have. as it's a new account, I can't comment on your answer or vote for it yet, sorry! :) –  tehwalrus Feb 11 '12 at 23:16
    
Reading that page, I see those configurations are valid for Ubuntu 10.10. According to this page it should not be necessary to change xorg.conf. Have you tried using it without changing xorg.conf? –  Alexandre Feb 12 '12 at 22:57
    
See the edited answer: yes, I've tried with both. All editing xorg does is break the nice velocity-dependent pointer movement, it doesn't help with anything. :( –  tehwalrus Feb 13 '12 at 8:49
    
If I got it right, things work properly when you login on Unity 2D, right? I believe you should consider reporting an issue in the project page. –  Alexandre Feb 13 '12 at 13:42
    
no, sadly, while touchegg can see the events go past, it seems to ignore my preference and still maps all 3-finger gestures to nautilus window move. in compiz-unity is just can't see any events at all, so at least two bugs! I will investigate myself when I have time, and just live with ctrl+opt+arrows to move between workspaces :( –  tehwalrus Feb 13 '12 at 16:13
show 1 more comment

1 Answer

up vote 0 down vote accepted

Touchégg should allow you to do what you want.

The main application can be installed from repositories (click here to install itInstall touchegg).

In order to configure it you have to install a separated package, it is not distributed with Ubuntu: 32 bits, 64 bits.

Source: OMG Ubuntu.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.