Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Minecraft installed but whenever I open it, it shows the login screen, so I login, and then when I click login, the window turns black. When I tried to play in in browser, the same thing happened except the window turned whit. Please help guys! I feel like I've tried EVERYTHING! Thanks! =)

Oh and if you want a better look at the problem, I've created this video that is a recording of my desktop and shows what happens when I try to run Minecraft.

http://www.youtube.com/watch?v=8CMsnwoUbEI

share|improve this question
add comment

2 Answers

Remove all your Java packages and start over.

  1. Install openjdk-6-jre
  2. Remove the hidden folder ~/.minecraft (folder .minecraft, located in your Home folder)
  3. Download the minecraft.jar from http://www.minecraft.net/download
  4. Create ~/.local/share/applications/minecraft.desktop containing (assuming that you have downloaded the file in ~/Downloads):

    #!/usr/bin/env xdg-open
    [Desktop Entry]
    Version=1.0
    Name=Minecraft
    Comment=Start Minecraft
    Exec=/usr/bin/java -cp ~/Downloads/minecraft.jar net.minecraft.LauncherFrame
    Terminal=false
    Type=Application
    Icon=minecraft.png
    Categories=Games;
    StartupNotify=false
    
  5. Find a nice icon on the Internet for Minecraft and save it as ~/.local/share/icons/minecraft.png
  6. To start Minecraft, run desktop file that you've created. You can copy it to your desktop as well.
share|improve this answer
    
The file didn't open, I ran through your directions three times and I think I did everything right. –  James Kosmopoulos Feb 13 '12 at 5:26
    
Can you open a terminal and run the command /usr/bin/java -cp ~/Downloads/minecraft.jar net.minecraft.LauncherFrame ? Please add the output of it to your question. What fails? –  Lekensteyn Feb 13 '12 at 9:25
    
Yes I can run it. But the same thing happens, the window turns black. –  James Kosmopoulos Feb 14 '12 at 2:04
    
Is there any output from the terminal command? What does the command update-alternatives --display java output for you? –  Lekensteyn Feb 14 '12 at 9:03
    
This is what happens when it shows the login screen. (java:2502): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", (java:2502): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", (java:2502): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", (java:2502): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", –  James Kosmopoulos Feb 14 '12 at 13:11
show 5 more comments

Installing the proprietary Drivers might help.

Go to the dash, search for Jockey, and install the Driver for your Graphics Card .

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.