Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There doesn't seem to be any ri documentation on core ruby classes on my system. Using ri -c I see that there are docs for a few gems I've installed, but that's it.

$ ri Array
Nothing known about Array

I'm using the standard system ruby1.8 (1.8.7.352-2). I'm not using rvm. Is there some other package I need to install? On a very similar machine (also Oneiric with ruby 1.8) ri Array works just fine, and I can't tell what the difference is.

ruby -v on the problematic machine:

ruby 1.8.7 (2011-06-30 patchlevel 352) [i686-linux]

and on the normal machine:

ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
share|improve this question
    
Can you add the full output of ruby -v on both machines to your question? Thanks. –  jrg Feb 11 '12 at 13:30
add comment

1 Answer

up vote 0 down vote accepted

Lo and behold, there is a package. In my defense, there are so many hits for aptitude search ri that I didn't see it.

apt-get install ri1.8
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.