Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP DM4 Beats Edition running Ubuntu 11.10. The HP Pavillion runs on-board Intel graphics as well as Radeon GPU.

From what I have read it appears that the Radeon GPU is draining my battery and also causing the laptop to overheat. Battery life is down to under two hours when using the machine for simple tasks and the unit is heating up excessively.

I tried activating the ATI FGLRX driver - but it was not successful. I also have installed the CPU control applet.

For now i just want to disable the GPU and use the Intel on board graphics.

Is there a way that I can force the system to just use the Intel Graphics?

I am very new to Ubuntu and need some basic help.

share|improve this question
    
when i did echo OFF > /sys/kernel/debug/vgaswitcheroo/switch it shows permission denied I had done chmod and chown –  user46951 Feb 18 '12 at 15:29
    

2 Answers 2

Ubuntu comes with vgaswitcheroo since 10.10. Therefore you can although it is far away from working as smooth as on Windows. Yet it's enough to turn off either one of the cards and/or switch to using the other ones.

You find more information on this topic on help.ubuntu and this linux.blogspot.

Since you are fairly new to Ubuntu, I'll tell you the essential commands:

chmod -R 705 /sys/kernel/debug # this isn't noted on the help.ubuntu-page, yet I had to do this since 11.04
chown -R $YOURUSERNAME:$YOURUSERNAME /sys/kernel/debug/vgaswitcheroo # where $YOURUSERNAME is your user name
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch # this will turn off your currently unused card. This is normally the discrete one.

These commands shouldn't work with fglrx installed I guess, because it has its own switching mechanism (which doesn't work for me).

For switching between cards, you would write DDIS (for discrete) and DIGD (for integrated) instead of OFF. Note that you will see a change only after you have logged off. Still the other card will already be turned on; consuming power and spinning its fan.

share|improve this answer
    
Thanks for your help –  Bill Feb 11 '12 at 22:15
    
Just fyi - i tried to install a switch program from support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx - it seemed to work just fine until i switched to the Intel on-board GPU - it failed on shutdown and hung with some serious looking errors, half killed my Ubuntu install, - i just reinstalled Ubuntu 11.10 from the DVD - which was a lot easier than i had expected. A new learning experience :) –  Bill Feb 11 '12 at 22:37
    
Hi - Thanks - I tried this and it works but when I reboot the settings revert to the Radeon (I need a screwdriver to ditch the thing) –  Bill Feb 12 '12 at 5:53
    
$ sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch # bash: /sys/kernel/debug/vgaswitcheroo/switch: Permission denied Notebook-PC:~$ sudo su wgiwgi18# echo OFF > /sys/kernel/debug/vgaswitcheroo/switch # this works - but only for the current session?? –  Bill Feb 12 '12 at 6:02
    
Thanks for your help - I just managedto edit my rc.local file using "gksu edit /etc/rc.local" - i just added the one line at the top of the file "echo OFF > /sys/kernel/debug/vgaswitcheroo/switch" and it seems that the heating problem has been resolved, cheers Bill –  Bill Feb 12 '12 at 10:03

I'm using a Sony VAIO VPCSB2 laptop with switchable graphics (Intel integrated / ATI 6470M) and have lost a lot of time with this also...

Easiest way to solve the problem, as said above, is to add:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

to your rc.local file (sudo gedit /etc/rc.local, add before line "exit 0"). It quick and dirty, but will power off the ATI adapter at startup. The limitations are:

  • No ATI accelerated graphics, obviously :)
  • Bad sleep / suspend support (the ATI adapter may wake up together with the laptop...)

Since release 12.1, the Catalyst drivers do support hybrid graphics, on my notebook at least, but it required a bit of work (not sure that all steps are required in the end, but at least it worked):

Make sure that you don't use vgaswitcheroo already :)

Prerequisites install

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

On a x64 system, add:

sudo apt-get install ia32-libs

Create this symlink (this prevented the driver package compilation to fail later on in my case):

sudo ln -svT lib /usr/lib64

Download the driver from ATI and create the packages:

sh ./ati-driver-installer-11-11-x86.x86_64.run --buildpkg Ubuntu/oneiric

Install the packages:

sudo dpkg -i fglrx*.deb

Configure the driver:

sudo aticonfig --initial -f

Reboot and pray. If it works you will be presented with your standard login prompt. Log in and start the Catalyst Control Center as an administrator. You can then finally choose in a GUI which GPU you want to use (reboot required).

If it does not work (you have to login in a command prompt) and you want to retry, do some cleanup before restarting the procedure:

sudo aticonfig --uninstall    
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

The big disadvantage with the Catalyst driver is that Unity will work only in 2D mode on the Intel adapter (with the "native" intel driver, standard Unity works well).

I found no solution for this last problem, therefore in my case I switched back to the switcheroo solution.

share|improve this answer
    
thanks for your help –  Bill Feb 11 '12 at 22:15
    
Thanks for your help i just edited my rc.local with "gksu gedit /etc/rc.local" from the terminal and added the line as suggested. It seems that i have gained at least an extra hour of runtime on battery power , and the machine is much cooler and happier. :) thanks Bill –  Bill Feb 12 '12 at 9:59
    
@Bill If you find an answer helpful you can thanks the answerer by upvoting their answer, see faq. –  N.N. May 24 '12 at 11:24
    
It doesn´t matter when sudo aticonfig --uninstall doesn`t work. And when you remove the ATI driver don't forget to install de open source driver again. –  OrangeTux Aug 8 '12 at 12:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.