Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried to install Ubuntu 11.10 x64 and x86 a couple of times onto a new OCZ Vertex 30GB, with Ext3 and Ext4 partitions. After installing, it reboots into Ubuntu properly, but hangs on shutdown. After a few hours, I held the power button to shut it off.

When I reboot, I get:

error: unknown filesystem
grub rescue>

i basically used the auto settings for install, but tried some variations (3gb swap and 27gb / as sda1 and 5 and the other way round. tried with ext3 and 4 and btrfs.

I tried automatic partitioning for installation, and some variations(3GB swap, 27GB as sda1 or sda5) I have tried Ext3, Ext 4, and btrfs.

I tried Boot-repair via Live USB, asl well as manually reinstalling GRUB, but to no avail.

is it because of the ssd? do i need to TRIM? i thought 11.10 would do that for me...

Is this due to my having an SSD? Do I need to trim?. I thought 11.10 would work.

I appreciate every tip and hint, as well as a solution. Thanks in advance.

My machine is a 3 year old Lenovo n100, core2 duo.

share|improve this question
1  
Sounds like you may have a bad drive. I have a 64 gb vertex I got a year ago for what it's worth. You might take a look at dmesg to see if there were any kernel errors during the update before you reboot. –  psusi Feb 11 '12 at 4:27
add comment

2 Answers

There are compatibility issues with the 945G chipset and you are probably unlucky to have this one in your notebook.

http://www.ocztechnologyforum.com/forum/showthread.php?93863-Vertex-Plus-60GB-OCZSSD2-1VTXPL60G-won-t-work-on-Gateway-LT2016U-netbook

In the third post a user describes the same issues you are experiencing. Chipset name, BIOS and SSD firmware version numbers would be nice to have in those cases.

I hate to tell you this, but you are probably really out of luck. I searched for a BIOS update of this computer and saw that the latest one is from mid 2007. SSDs hit the market a few years later, which sounds like no one ever fixed this. Also note, you may have bought your notebook 3 years ago (2008/2009?) but the particular product is from 2006. Installing a SSD brings a performance boost in most cases, but this sounds not quite like the right upgrade path, best choice would be to save that money spent on the SSD. It sounds sad and pessimistic, I know, but it's the honest advice I could give you

http://support.lenovo.com/en_US/downloads/detail.page?&LegacyDocID=MIGR-67008

share|improve this answer
    
ok. thx for your afford anyways. looks like that´s the case. grrrr. the time i already spend on trying to make it work would have been worth buying a brand new machine... the ssd was only €40 and i love how fast it boots and opens programs. on my desktop it runs just fine. but it runs on a Gigabyte Z68X-UD4-B3 mainboard. so i guess i´ll just order a spinning hdd. –  user45904 Feb 11 '12 at 15:46
    
compability error. just installed it flawlessly on a (non ssd) samsung drive. too bad. the lenovo n100 just seems to be a bit out of date. thx for the help anyways. saved me lots of hours of research time –  user45904 Feb 11 '12 at 19:58
add comment

I had this exact problem with an Asus EeePC 1101HA laptop and a 120GB OCZ Vertex Plus drive, and solved it by upgrading the firmware of the drive to version 3.55.

I used the software posted here to update the firmware from a bootable USB drive, set-up with UNetbootin. (Should that link to the OCZ forum die, I expect that the firmware posted on the main OCZ website will do a similar job.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.