Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu on my MacBook 2007 with a Spanish keyboard, on MacOS the @-sign was typed using Alt (Option) + 2, but on Ubuntu I have no idea. I have to copy and paste it every time. How do I type an at sign?

share|improve this question
add comment

4 Answers 4

Make sure you selected the right keyboard layout. Go to System Settings, click on Keyboard Layout. On the Layout tab you should see a + button. Select the most appropriate keyboard layout as shown bellow.

keyboard layout dialog box

I am not using a Macbook, but the first layout worked as you described to type @. I suppose you are using Ubuntu 11.10.

share|improve this answer
    
yes, im using 11.1 . the first one didnt work also. i guess because it's a mac keyboard. if I press the alt key the current program running shows the options bar(file, edit, view..) –  Luigi Feb 11 '12 at 3:51
    
@Luigi have you tried the Spanish (macintosh)? –  Alexandre Feb 11 '12 at 13:22
    
same problem here and no solution so far. the (at) @, tilde (~) and brackets [] to mention just a few also don´t work for me on an earlier mbp. –  v2r Feb 21 '12 at 7:17
add comment

With Ubuntu 12.04 on a Macbook Danish keyboard, I get the @ sign with the right Alt+2. It doesn't work with the left alt key as normally on the Mac.

share|improve this answer
    
No. This is wrong. –  king_julien Mar 7 at 20:38
    
Actually, that's how I do that, but I'm on a Windows Keyboard, AZERTY-Belgium. –  MrVaykadji Mar 7 at 21:01
add comment

If you want to see where any particular character is on the active keyboard, click on the Keyboard applet in the top right corner of the screen and select 'Show Layout Chart'. You will be shown a detailed plan of your currently selected keyboard layout.

share|improve this answer
add comment

I have a macbook pro model 2,2 I found a way to map the 3rd symbol easily. In ubuntu 12.04, in system setting -> keyboard configuration, choose options, there is a option called 3rd level (in spanish Tecla para seleccionar el 3er nivel), I chose the numeric intro that is the right key beside the right mac cmd key, and there you have it presing that key plus 2 I get the at symbol.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.