Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Gnome-shell on Ubuntu 11.10.

For some reason, after I added the usual extensions (Weather Indicator, System Monitor etc) the clock moved to the right - I did not install an extension for it to do so; it just did.

How can I get the clock back to the center?

share|improve this question

(converted OP answer originally in his/her question)

The solution I found to this is as follows.

  1. Click the system monitor,
  2. go to preferences and
  3. untick 'move the clock'.
share|improve this answer

Another extension that causes this behaviour is "Extend Left Box" -- I had so many extensions that I didn't notice it, and then I installed "Status Area Horizontal Spacing" and had to poke around a bit.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.