Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I thought I already had the time up there in the top bar, and it may have been so in previous Ubuntu versions (don't remember, my Ubuntu laptop is just one of three computers I use). Only that I just noticed - me being someone who never wears a watch, has the cellphone turned off 95% of the time and relying on the computer to tell the time - that there is no time being displayed anywhere, and I had expected it in the top bar on the Unity desktop.

I searched around but found no obvious solution, but I'm sure someone immediately knows how I can get my time (back?) into the top bar?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

The time is shown by default, so it looks like you've changed something to make it disappear.

Do you still see the date? Right-click the date, select "Time & Date Settings", go to the "Clock" tabsheet, make sure that "Show a clock in the menu bar" is checked.

If you don't see the date, go to System Settings, where you'll also find the "Time & Date" settings.


There is no longer a "Time & Date" setting in System Setting - Ubuntu 12.10 - but this link describes how to enable these on the display:

(note: dconf-editor is already installed by default)

How to make the date appear next to the time indicator in Gnome Classic?

share|improve this answer
    
I'm not aware I changed something. I definitely didn't deliberately do so. No, no date either. There is no time&date in the "system settings" window...(?) –  Mörre Feb 10 '12 at 10:36
2  
Case closed - I had removed everything using "evolution", and teh indicator applet was one of those packages. Why on earth it needs evolultion(-data-server) is another question (I understand - calendar data; but didn't they switch to Thunderbird). I declare your answer a "solution" because it helped me find the problem. –  Mörre Feb 10 '12 at 10:39
    
I had the same problem. Just to add specifically, installing indicator-datetime is what fixed it. –  DisgruntledGoat May 8 '12 at 23:50

If after installing the app and correcting config, the date&time are "greyed-out", then it means your chosen region is not matched to your local server.

To correct:

1/ set the time&date to your actual region (eg China)

2/ use synaptic to select the repository server for your actual region (eg China).

3/ reboot.

This should solve the issue. Recurrence may be caused by change in location, or change in server, or update/upgrade. If so, repeat the above.

share|improve this answer
    
Uhmm.... this question has already had an accepted answer - meaning a working solution - for more than a year! Thanks, but you really shouldn't have bothered :) –  Mörre Dec 14 '13 at 9:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.