Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Cinnamon two days ago in Ubuntu doing this:

sudo add-apt-repository ppa:merlwiz79/cinnamon-ppa
sudo apt-get update
sudo apt-get install cinnamon cinnamon-session cinnamon-settings

But when I try to start a new session in Ubuntu with Cinnamon, it starts Gnome Classic instead Cinnamon. I don't know why, but could it be possible because there's no cinnamon-session and cinnamon-settings in the repository? I have watched videos of the installation and there was no problem, but when the videos were recorded there were those packages.

I just tried to install Gnome Shell and it happens the same thing. I can run Unity 3D and 2D.

I'm using VirtualBox, but I don't think that could be the problem, right?

(I'm using Ubuntu 11.10 64 bits)

share|improve this question
Are you able to run Unity3D or GNOME shell without issues? – Bruno Pereira Feb 10 '12 at 10:24
@BrunoPereira - that should be an answer... :) – fossfreedom Feb 10 '12 at 14:00
@fossfreedom depends on the reply from the user :) – Bruno Pereira Feb 10 '12 at 14:03
Are you certain that you are indeed running Unity 3D? The Ubuntu (Unity 3D) login target in 11.10 will automatically fallback to Unity 2D if there is no 3D acceleration. – Mark Bidewell Feb 10 '12 at 17:45
@Pepe - please add your solution as an answer and you can accept it via the tick button. Thanks. – fossfreedom Feb 11 '12 at 12:47

I enabled 3D aceleration in the virtual machine and problem solved. Thanks!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.