Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am experiencing a problem. I tried to plug in my external hard disk on Ubuntu. I copied in to it some folders (created on Ubuntu) with files in them.

Then, I plugged it on Windows and I wasn't able to copy or modify any of the copies folders or sub-folders. I could access my files (and modify them), but I couldn't modify or copy any of the folders or sub-folders.

I tried formatting my computer's and the external hard disk, that did not make a difference.

What should I do?

wimvds --> Thanks for your answer, first of all :) Yes! I did. I always use "Unmount" on linux as well as on windows...

Misery --> No errors are promoted during the copy process. What do you mean by saying "attributions"?? :/

share|improve this question
    
Did you by any chance just unplug your HDD? If so you should mount it again in Linux and click the Unmount icon (eject button icon) next to the external HDD before unplugging the device. –  wimvds Feb 10 '12 at 8:04
1  
Ubuntu recognizes NTFS partitions without any problem so it should work normally. Does it prompt any error while copying folders from Your HDD to Windows? Did You try to right-click on the folders and see what attributes they have? –  Misery Feb 10 '12 at 8:15
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. This is to help with the Ask Ubuntu Clean Up. If you feel this question is not abandoned, please flag the question explaining that. :) –  Seth Jan 1 '13 at 17:01
add comment

7 Answers

As others have said this is file permissions.

Use Microsoft's "xcacls" (a downloadable tool by Microsoft for Windows sysadmins) because I believe it's a Windows issue. I used to see this on Windows Servers sometimes when the ACL (Access Control List) is borked.

Take ownership of everything (important) and then assign 'full control' access level.

You shouldn't have to do it each time.

share|improve this answer
add comment

There might be a problem with file permissions. Right click on the folder and choose "Properties" (in Windows) and see if you have permission to access it. If not, change the file permissions in Ubuntu.

share|improve this answer
add comment

What types of files are you trying to access from the windows machine? Have you tried copying those files using the windows cmd window? Try using chmod -r 777 on the folder in the hard drive. Also, have you tried zipping the folder on Ubuntu, then copying that file over to the external HDD? Also, have you done anything to the external HDD since you bought it? Maybe it has some type of copy protection mechanism.

share|improve this answer
add comment

On the Ubuntu machine, make sure you don't have it set to encrypt your home folder, and as to the Windows side, if you are admin, you shouldn't have any problems.

share|improve this answer
add comment

Ok, This most likely was your problem. When the USB was created it was made to only be compatible with Ubuntu (ext 2, ext 4, or encrypted). What you need to to to fix this problem is format the USB as 'FAT' compatible with all systems. This should solve you problem. I had this very dame problem.

share|improve this answer
add comment

It sounds like the NTFS read-only attribute has been set. Check in Windows that the files do not have the read-only attribute set. I've never seen this happen with an NTFS filesystem used under Ubuntu.

If it's ext2 or ext4, what ext driver have you installed to access the ext partition?

share|improve this answer
add comment

The file you copied might be encrypted or it could be what @Shannon_VanWagner posted...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.