Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a small partition for linux and a big partition that is ntfs so I can share files with my windows installation.

I want to use transmission-daemon (this is a console-only installation) and I want it to download in the ntfs partition.

The problem is that transmission reports "Permission Denied" when trying to save the downloaded torrents. I assume this is because all permissions on ntfs are rwXwrX--- (which means no access for other users, and transmission-daemon is other user). The worst part is that I cannot chmod o+rwX /media/ntfspartition/torrents/ -- it just doesn't work, it's ntfs.

In this particular case neither can i use transmission-gtk

So, how can I make transmission-daemon download to a ntfs folder?

Thanks in advance for your help.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Well, looking at the script that is put in /etc/init.d/transmission-daemon, the user name we want to ensure has the proper permissions is called debian-transmission. Given that NTFS does not support Linux permissions, we have to mount the NTFS partition in a way that will let debian-transmission write to it.

We want to add debian-transmission to a certain group (one where you are also a member, obviously) and let that group have write access to the partition.

The steps are as follows:

  1. Add a group, say ntfs-users.
  2. Add yourself to the group.
  3. Add debian-transmission to the group.
  4. Edit /etc/fstab as per detailed instructions here.
  5. You need to log out and in again to have the new group membership, as does debian-transmission (restart service), and the partition has to be unmounted and mounted again. Either do all of those manually, or just restart your system if that is an option.

From how you phrased your question, it seems that you are proficient with Linux, so I will assume that you can either carry out those steps without further instruction or find out how with ease. Best of luck. :-)

share|improve this answer

I simply noticed that NTFS partitions are mounted as root:plugdev, so I simply did:

usermod -g plugdev debian-transmission

I added debian-transmission user to plugdev group and now no problem!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.