Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I restarted my computer and now they are all out of order, how do I put them back in the proper order? alt text

share|improve this question
    
What do you mean by "out of order"? –  Alvin Row Oct 29 '10 at 17:51
    
@DoR, refer to the new screenshot. –  TheX Oct 29 '10 at 17:57
    
I have been having this same issue since Ubuntu 10.04. Haven't seen it on 10.10 yet. Have you done the upgrade? –  Mark B Oct 29 '10 at 18:39
    
Yes I am using 10.10 –  TheX Oct 29 '10 at 19:27
add comment

4 Answers

up vote 3 down vote accepted

Move your current panel configuration so it is no longer used:

mv ~/.gconf/apps/panel ~/panel_backup

Log out and then log back in, you will now have the default panel setup.

share|improve this answer
    
This worked thanks. –  TheX Oct 29 '10 at 19:28
add comment

You can move any panel applet by right clicking on it (right click just between the items in the notification area), unticking 'Lock to Panel' and clicking 'move'. You can then drag it along the panel with your mouse and drop it with a left click. Aftwerwards, right click again and tick 'Lock to Panel'.

right click move

You can refresh the panel by pressing Alt+F2 and entering killall gnome-panel or you can enter xkill and then click on the panel.

killall gnome-panel

share|improve this answer
    
This did not arrange the icons in their proper order. –  TheX Oct 29 '10 at 17:58
    
Try right click > move, making sure 'Lock to Panel' is unticked. –  dv3500ea Oct 29 '10 at 18:01
1  
You also want to make sure to Lock them back in place when you're done moving them, or they'll just jump around again. –  frabjous Oct 29 '10 at 18:29
add comment

Have you ever plugged in an extrnal monitor or moved the icons around? I noticed this seemed to start for me after plugging in an external monitor and enabling it in the Nvidia settings for the first time.

share|improve this answer
add comment

Another trick is to killall gnome-panel. This works mainly for visual glitches, but may also work for arrangement.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.