Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to upgrade and while doing so, I get the following:

devteam@hephaestusx:~/Projects$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libboost-python-dev : Depends: libboost-python1.46-dev but it is not installed
E: Unmet dependencies. Try using -f.
devteam@hephaestusx:~/Projects$ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
devteam@hephaestusx:~/Projects$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libboost-python1.46-dev libboost1.46-dev
Suggested packages:
  libboost1.46-doc libboost-date-time1.46-dev libboost-filesystem1.46-dev libboost-graph1.46-dev libboost-iostreams1.46-dev
  libboost-math1.46-dev libboost-program-options1.46-dev libboost-random1.46-dev libboost-regex1.46-dev libboost-serialization1.46-dev
  libboost-signals1.46-dev libboost-system1.46-dev libboost-test1.46-dev libboost-thread1.46-dev libboost-wave1.46-dev doxygen default-jdk
  fop
The following NEW packages will be installed:
  libboost-python1.46-dev libboost1.46-dev
0 upgraded, 2 newly installed, 0 to remove and 2 not upgraded.
6 not fully installed or removed.
Need to get 0 B/8,151 kB of archives.
After this operation, 80.1 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 226442 files and directories currently installed.)
Unpacking libboost1.46-dev (from .../libboost1.46-dev_1.46.1-5ubuntu2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libboost1.46-dev_1.46.1-5ubuntu2_amd64.deb (--unpack):
 trying to overwrite '/usr/include/boost/aligned_storage.hpp', which is also in package libboost1.40-dev 1.40.0-6ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libboost-python1.46-dev (from .../libboost-python1.46-dev_1.46.1-5ubuntu2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libboost-python1.46-dev_1.46.1-5ubuntu2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libboost_python-py26.a', which is also in package libboost-python1.40-dev 1.40.0-6ubuntu1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.46-dev_1.46.1-5ubuntu2_amd64.deb
 /var/cache/apt/archives/libboost-python1.46-dev_1.46.1-5ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any idea on how to remedy this?

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

You currently have libboost1.40-all-dev from Maverick installed. Now you are trying to install libboost1.46-dev from Oneiric. It's similar for libboost-python1.46-dev.

That doesn't work, mixing packages from different versions of Ubuntu only works in very few special cases.

Try to remove the packages libboost-python1.46-dev and libboost1.46-dev.

share|improve this answer
    
I suppose I want to remove the Maverick install and install the Oneiric version. –  kenneth koontz Feb 9 '12 at 17:56
    
Thank you very much! $ sudo aptitude remove libboost-python1.46-dev && sudo aptitude remove libboost1.46-dev Worked! –  kenneth koontz Feb 9 '12 at 18:04
add comment

Root privileges are needed for apt-get upgrade too, so:

sudo apt-get update && sudo apt-get upgrade

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.