Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have setup a wireless ad-hoc connection between two laptops: one running ubuntu and the other MS XP. I have assigned static IP to both the laptops and both get connected quite easily. I can access all ubuntu services like ssh, squid, samba from the laptop running MS Windows. But from Ubuntu machine I cannot access any Windows services like shared directories etc. The Windows machine doesn't even respond to ping requests from ubuntu.

share|improve this question
    
have you configured the windows XP computer to allow sharing? Also check the settings of the connection and ensure that (I think it's called MS Internet client services or something like that, sorry I don't remember offhand) are enabled (right click the connection and click properties). –  RolandiXor Oct 29 '10 at 20:15
    
Is the firewall running on the Windows XP machine? –  cprofitt Nov 8 '10 at 16:14
add comment

4 Answers 4

up vote 2 down vote accepted

To be honest this sounds like the Windows Firewall is running. You will want to disable the firewall on just the 'adapter' you created to make the ad-hoc connection.

share|improve this answer
    
I have tried turning the firewall off on windows, still it did not work. The shared directories are visible on windows machines but not on ubuntu. –  nixnotwin Nov 8 '10 at 16:30
add comment

Actually you dont even need to install any tool.

On the Ubuntu machine sharing an internet connection.

  1. Go to Network Connections
  2. Then Wireless Connections
  3. Then Add
  4. Enter a SSID, choose mode : Ad-Hoc
  5. IPv4 Settings choose as a method : shared to other computers
  6. (you may want to establish a wireless security)
  7. Connect to the network (if you do not see it, you may disable and then enable your network manager)

On the Windows machine after the ubuntu machine is connected to the Ad-Hoc Network

  1. See the Wireless Networks and connect to the wireless network.

Thats it. You should now be able to use the internet connection provided by the ubuntu machine.

Good luck

share|improve this answer
add comment

First, it won't respond to a ping... open up Network Connections, then right-click on your Ad-Hoc adapter and click Properties. Go to the Advanced tab, and click Settings under ICMP. You want to make sure "Allow incoming echo requests" is checked here. If it is, then Windows probably isn't explicitly blocking the ping.

Just to rule it out, what are you using for a gateway address in your Static IP setup? Presumably it should be the static IP of the Windows laptop.

Do you have any other Windows boxes you could connect to the ad-hoc network? It might be worth testing their ability to see the network shares of the XP machine.

share|improve this answer
    
I have left gateway option blank. Windows xp machines sea each other perfectly well. –  nixnotwin Nov 9 '10 at 13:49
    
Try setting the gateway on the Ubuntu machine to the static IP of the Windows machine. –  ayan4m1 Nov 9 '10 at 22:02
add comment

install and configure firestarter tool, when finised, create ad-hoc connection then change the IPv4 method to "shared to other computer".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.