Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a zram swap (and a normal one) and I got no idea where it came from:

$ sudo blkid | grep zram
/dev/zram0: UUID="..." TYPE="swap"

$ lsmod | grep zram
zram                   18642  1

$ cat $ cat /etc/fstab
# <file system>         <mount point>   <type>   <options>                             <dump>  <pass>
proc                    /proc           proc     nodev,noexec,nosuid                   0       0
tmpfs                   /tmp            tmpfs    defaults,noatime,mode=1777            0       0
UUID=...                /               ext4     discard,noatime,errors=remount-ro     0       1
/dev/disk/by-uuid/...   /mnt/data       ext4     defaults,user,exec,errors=remount-ro  0       2
/dev/disk/by-uuid/...   /mnt/media      ext4     defaults,user,errors=remount-ro       0       2
UUID=...                none            swap     sw                                    0       0
  1. Where did come from?
  2. How can I get rid of it, besides blacklisting zram?

This is happening only on one of my systems, both running Ubuntu 12.04 Alpha 2+.

share|improve this question
1  
Did some nasty package install zram-config in your system? –  Bruno Pereira Feb 9 '12 at 12:56
    
Nope, not installed. –  htorque Feb 9 '12 at 14:06
    
zram is in fact a useful tool, so I recommend that you keep it. It is most effective on systems with low RAM; e.g. Lubuntu uses it. –  Paddy Landau Mar 17 at 20:18

2 Answers 2

up vote 4 down vote accepted

I forgot to check the files in /usr/share/initramfs-tools and indeed, I found some compcache related files. I then checked, which package installed those files, e.g.

sudo dpkg -S /usr/share/initramfs-tools/conf.d/compcache

points to the package casper. Now, I got no idea how this ended up on my system, but purging it and recreating the initrd, gets rid of the zram swap.

share|improve this answer

In 12.04 final this is part of initramfs-tools:

$ lsb_release -rd
Description:    Ubuntu 12.04.2 LTS
Release:    12.04
$ dpkg -S /usr/share/initramfs-tools/hooks/compcache
initramfs-tools: /usr/share/initramfs-tools/hooks/compcache
$
share|improve this answer
    
Note though that the initramfs-tools support does nothing unless enabled in /etc/initramfs-tools/initramfs.conf. –  Tristan Schmelcher Mar 13 '13 at 5:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.