Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am quite a noob in network/server stuff and I don't really know where to begin. I am using Ubuntu Lucid 10.04 on my PC, and I have also Debian SSH server on another machine in my LAN. I would like to be able to use a graphical session from Ubuntu while accessing Debian server. Is it possible, and how to do it?

I haven't installed any graphical environment on Debian SSH server, because it has no attatched monitor. When it had GNOME or XLDE installed it freezed while loading the system, with no monitor connected. So now it works only in text mode.

I can access it via ssh without any problem, but how do I make a graphical session?

EDIT: For example I would like to view and manage folders just like in nautilus.

Thanks in advance, Regards

share|improve this question
    
In the graphic session, What all do you want? –  Amith KK Feb 9 '12 at 9:33
    
Try xrdp . It doesen't run on ssh but uses the Remote Desktop Protocol –  Amith KK Feb 9 '12 at 9:35

1 Answer 1

up vote 8 down vote accepted

Only connecting to manage folders from Nautilus

To do this, you only need ssh installed on the server.

Go to File>Connect to Server

Fill the dialog up with the settings like so:

Make it a bookmark

Use the bookmark whenever required


As far as SSH is concerned, AFAIK its not possible to Xforward a whole session

Note: You need a graphical environment for this

What you want to use is probably XRDP

On the Debian install run the following command

sudo apt-get install xrdp

And on ubuntu, do this:

sudo apt-get install remmina&&remmina

You'll get this window

Click New

Configure the settings

Click the connect button

You will get a session which has a gui of the server

share|improve this answer
    
@Misery I've edited it. –  Amith KK Feb 9 '12 at 10:11
    
The nautilus solution is great!! Thanks a lot! That was something I was looking for:] –  Misery Feb 9 '12 at 10:14
    
@AmithKK you forgot to mention that in order to have an RDP session you'd need a GUI installed on the server you're RDP-ing to. –  Thomas W. Feb 9 '12 at 16:21
    
From the question @ThomasWard , He already seem'd to have LXDE installed –  Amith KK Feb 10 '12 at 7:31
    
@AmithKK then you didnt read. "I haven't installed any graphical environment on Debian SSH server, because it has no attatched monitor. When it had GNOME or XLDE installed it freezed while loading the system, with no monitor connected. So now it works only in text mode." –  Thomas W. Feb 10 '12 at 8:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.