Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu form a CD on my laptop and on my desktop PC (both with Windows XP).

After installation I can choose what system should be booted, Windows XP or Ubuntu, on my laptop and it works fine, but on the desktop after rebooting, Windows XP starts and I have no way to boot Ubuntu.

share|improve this question
Did you install Ubuntu "As a program" within Windows? (Using Wubi). – RolandiXor Feb 9 '12 at 15:21

EasyBCD does not work with XP - needs Vista or 7.

Best solution for starters is boot-repair. When you run boot-repair be sure to update it before running it - it gives you that option.

If the one click option does not work, you can try the Purge and reinstall option.

share|improve this answer

Please run msconfig.exe and find option responsible for displaying other systems. Set time for lets say 30 seconds.

share|improve this answer
ok i will try it after work, and post info. – i20918 Feb 9 '12 at 8:44

Run GParted from the live-CD on your desktop machine and verify that the installer has set up the root and swap partitions for Ubuntu. If these are present, it probably means that, for some reason, the installer failed to reset the Windows master boot record (MBR) so that the GRUB dual-boot menu isn't being initiated. If this is the problem, try using Boot-Repair to rectify the situation. Complete instructions on how to download, install and use Boot-Repair are available at: If this doesn't work, just try re-installing Ubuntu on the desktop. It's quite likely that you have experienced just a transient glitch.

share|improve this answer
Boot-Repair solved the problem. Thx for help. – i20918 Feb 9 '12 at 22:05

Download EasyBCD and add Ubuntu to the Windows Boot Loader.It's fairly easy to do so with EasyBCD. You should be able to boot to Ubuntu on startup then.

share|improve this answer
The asker is using Windows XP, so this will not work. – RolandiXor Feb 10 '12 at 18:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.