Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I close the lid of my laptop and open it after some time I am greeted with a message "Failed to suspend". When I tried to manually suspend/hibernate, I saw these options are not available there at all. Of course, they did exist when I did the fresh installation but I can't see them anymore.

I am totally pissed off with this. Please help.

share|improve this question
    
Are you using Wubi? Wubut doesn't fully support suspend/hibernate. –  TheX Oct 29 '10 at 16:28
    
No I use ubuntu as a sole operating system on my laptop. –  Gaurav Butola Oct 29 '10 at 16:36
    
That was supposed to be Wubi, Wubut. –  TheX Oct 29 '10 at 17:19
    
wubut? I meant, I only use Ubuntu, so no wubi. –  Gaurav Butola Oct 29 '10 at 17:32
    
Can you provide any more detail of what model of laptop or what hardware you have. That will help troubleshoot the problem. –  cprofitt Nov 1 '10 at 14:14
show 1 more comment

3 Answers

up vote 3 down vote accepted

Finally I was able to resolve the problem by installing acpi-support from the ubuntu software centre. Here is the thread that helped me http://ubuntuforums.org/showthread.php?t=1608752

share|improve this answer
add comment

I know you've solved this, but I want to mark it as answered in the system:

Installing acpi-support can bring the suspend/resume back, sometimes issues are fixed in kernel updates and sometimes (rarely) issues are fixed in a bios upgrade.

share|improve this answer
add comment

Had kind of same issues with my toshiba satellite. After wondering around for long time I ended up installing the new kernel 2.6.36 from here, http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.36-maverick/

It seems to have resolved the issues at least when I am suspending from command line sudo pm-suspend. If I close the lid still haven't figured it out why its not working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.