Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got orchestra installed and running, and I have managed to build my first three nodes. Now I want to get down to the business of managing their environments.

I've installed JuJu on my main orchestra server, and I have generated the keys needed, and I have run the juju bootstrap

When I run juju status, I get the following error:

Cannot connect to machine MTMyODcyMjk5MS4wMTAwNDY4LjQ1NTcxMg (perhaps still initializing): Invalid SSH key
2012-02-08 20:19:21,565 ERROR Cannot connect to machine MTMyODcyMjk5MS4wMTAwNDY4LjQ1NTcxMg (perhaps still initializing): Invalid SSH key

Do I need to copy the public key over to the machines? There is nothing in authorized_keys for the user that juju is connecting as...

Do I need to be logged in as that user on the master server when I run the juju bootstrap command?

I'm using Orchestra to build these machines, and they create an ubuntu user on them, but there is no ubuntu user on the machine that is running orchestra.

UPDATE:

I have created an ubuntu user on the orchestra server since there is an ubuntu user on the nodes that I want to manage. I have also copied the public keys to the nodes themselves.

Now I get a very different error:

ubuntu@sid:~$ juju bootstrap
2012-02-09 09:14:47,931 INFO Bootstrapping environment 'orchestra' (type: orchestra)...
2012-02-09 09:14:48,043 INFO juju environment previously bootstrapped.
2012-02-09 09:14:48,045 INFO 'bootstrap' command finished successfully
ubuntu@sid:~$ juju status
2012-02-09 09:14:52,737 INFO Connecting to environment.
2012-02-09 09:14:53,800 ERROR Connection refused
Unhandled error in Deferred:
Unhandled Error
Traceback (most recent call last):
Failure: txzookeeper.client.ConnectionTimeoutException: could not connect before timeout
Cannot connect to machine MTMyODcyMjk5MS4wMTAwNDY4LjQ1NTcxMg (perhaps still initializing): could not connect before timeout after 2 retries
2012-02-09 09:15:22,925 ERROR Cannot connect to machine MTMyODcyMjk5MS4wMTAwNDY4LjQ1NTcxMg (perhaps still initializing): could not connect before timeout after 2 retries

Here's another thing I'd like to learn: How can you Un-Bootstrap an environment? In my case, I really think that something is screwed up, and I cant go and do another

juju bootstrap

because juju says that the environment has already been bootstrapped. can I undo this, and redo the bootstrap process?

Here is my environments.yaml file.

juju: environments
environments:
orchestra:
type: orchestra
# Specify the orchestra server
orchestra-server: '192.168.*.*'
# Specify storage.
storage-url: 'http://192.168.*.*/webdav'
# Specify cobbler's user/pass
orchestra-user: cobbler
orchestra-pass: *******
admin-secret: *******
# Mangement classes
acquired-mgmt-class: orchestra-juju-acquired
available-mgmt-class: orchestra-juju-available
default-series: natty
share|improve this question
    
It looks as though I need to have sshe setup across the nodes I want to manage before I do a juju bootstrap on an orchestra server. I'm doing some testing to confirm this. –  David Buttrick Feb 9 '12 at 18:30
    
It would be quite helpful if you included a redacted environments.yaml (redacted as in, take out any sensitive information like IP's/passwords). –  SpamapS Feb 12 '12 at 20:54
    
Did you solve your issue? Some problem, I can't get it... :( SSH logs only show "connection refused" Pretty weird because an ssh -i mykey ubuntu@ubuntu.local works great :( –  user46729 Feb 16 '12 at 22:06
    
I'm pretty sure that i have things configured correctly. SSH is working. The zookeeper gets installed, and appears to be OK. I edited the post to add my envrionments.yaml file. –  David Buttrick Feb 19 '12 at 20:14

1 Answer 1

up vote 0 down vote accepted

If bootstrap has returned, all that means is that juju was able to tell cobbler (the main piece of orchestra-provisioning-server) to boot the machine. If you don't have power control defined for the profiles/systems in cobbler, and/or you don't have PXE boot by default on that machine, you'll still need to manually reboot the server and cause it to PXE boot so that it installs a fresh Ubuntu and starts the juju agents on the first boot.

Also, if you didn't want bootstrap to "take" one of your real machines, you'll need to define a profile for a VM inside cobbler and then pxe boot that VM. Another way to hack this onto the cobbler server while you're still just messing with juju is to just read the pre-seed file that is defined for a fake system, and run the agents/zookeeper directly. That is beyond the scope of this question though.

The bare metal story is still very new in juju (it was as much a Proof of Concept as anything in 11.10), and is still evolving. I'd recommend following its progression on the juju mailing list and in #juju on Freenode, as its likely to get a lot smoother as the use cases become more clear.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.