Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I changed my monitor for a newer one. This new monitor has a darker image than my old one (for example, videos with dark scenes are now completely black). Bright and Contrast are 100% in monitor own menu and this are factory default values, monitor menu does not allow gamma adjust. This forced me to look for a solution.

Bright is not the problem, It is in gamma value. These commands work and image looks a lot better:

xgamma -gamma 1.5
xrandr --output VGA1 --gamma 0.6:0.6:0.6

the problems is that gamma go to 1.0 again when some of these events occur: user logoff, fast user switch, screen turn off after 10 minutes and then at the login prompt you press "change user".

The first I tried is to add in each user (four for this machine) xgamma in "startup applications", the problem is that whenever you get to LightDM login screen gamma go to 1.0 again. xgamma still says 1.5 when you launch it from terminal without arguments, but screen looks like using gamma 1.0 and you have to execute xgamma -gamma 1.5 again and again. This PC switch users very often, so I really don't like to have to constantly run xgamma after someone else come and switch from my session to another.

In my search for a system wide gamma setting, I finally concluded that creating a xorg.conf file is the only solution. My xorg.conf file looks like this:

Section "Monitor"

Identifier "Monitor0"
gamma 1.5

EndSection

Section "Screen"

Identifier "VGA1"
Monitor "Monitor0"

EndSection

That all the content of my xorg.conf file, I put the minimal settings to have the gamma I want and leave xorg to auto configure anything else.

It seems to work at first, you can tell that the monitor image is not so dark but if you stay one or two seconds in LightDM login screen gamma go to 1.0 again. I have to login and use xgamma again as only working solution. Launch xgamma from xinitrc script won't work, at least with the xorg.conf approach I can see lighter colors for a while at system boot, while using xgamma in xinitrc have absolutely no effect in gamma value (either in /etc/X11/xinit or per user, no matter if I write xgamma or full path to xgamma /usr/bin/xgamma).

It looks as if some piece of software or maybe an script is resetting my gamma, maybe LightDM itself. Or maybe something specific to my hardware?

Ubuntu 11.10 AMD64 (up to date, 2012-02-08)
CRT Monitor Siemens 17'' MCM 17P1
Intel GMA X4500 (onboard graphic card)
share|improve this question

closed as too localized by Luis Alvarado Apr 9 '13 at 13:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.