Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've compiled PHP 5.3.9 and NGINX 1.0.11 and want to use APC and Memcached with PHP. I keep getting this error when attempting to load the APC/Memcached modules:

Unknown(0) : Warning - PHP Startup: memcached: Unable to initialize module
Module compiled with build ID=API20090626,NTS
PHP compiled with build ID=API20090626,NTS,debug
These options need to match

I tried recompiling (configure, make, make install) PHP without the --enable-debug option, but still no luck. Any ideas on what I need to do to get these options to match?

share|improve this question

This error was resolved by compiling a new version (5.3.10) of PHP without the --enable-debug option.

share|improve this answer
you should give your answer the check – RobotHumans Feb 9 '12 at 4:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.