Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to create additional workspaces in Gnome-shell. Compiz says I should have four (2 by 2) but I only seem to have 2 set up. So, how do I create additional workspaces in gnome-shell?

share|improve this question
    
To clarify, what shell are you using on top of GNOME 3? Are you using Unity, GNOME Shell, GNOME Classic, etc.? –  WarriorIng64 Feb 8 '12 at 21:55
    
@WarriorIng64 Betcha its GNOME Shell. –  jrg Feb 8 '12 at 21:56
    
Gnome shell. The idea was to drop Unity, which I still hate three months in. But my login option just says "gnome" –  Amanda Feb 8 '12 at 23:17

2 Answers 2

up vote 6 down vote accepted

First of all, gnome shell doesn't use compiz, it uses mutter.

Second, gnome shell has something that I've dubbed "auto workspace maker" - that is, as you fill up one workspace, gnome creates another for you. So if you put a window in your first workspace and your second, gnome will make you a third workspace and so on and so forth.

share|improve this answer
    
that would explain why changing my compiz settings had no effect. –  Amanda Feb 8 '12 at 23:15
    
Dynamic workspaces :-). –  Timo Feb 8 '12 at 23:19
    
Huh. So does that mean I can't control how they stack? –  Amanda Feb 8 '12 at 23:47
    
Seems there are some tweaks available to break dynamic workspaces. I'll give them a try. piecesoflint.wordpress.com/2011/04/06/… –  Amanda Feb 9 '12 at 0:03
    
@Amanda I hope it works for you, but I'll warn you now that I didn't have much success with it when I tried it. –  jrg Feb 9 '12 at 1:44

Try Workspace Grid, a Gnome extension. It supports both up-down and left-right workspace navigation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.