Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wish to install a "legacy" php application (magento commerce 1.3) into a oneiric server. All the ppa's I've found hold packages for previous ubuntu versions.

I've tried to recompile php myself but the gd prerequisites are missing.

The same question for 10.10 is answered here

share|improve this question
    
I hate answering myself :-) since I didn't find any way to use the binary packages I resolved to compile php on my own –  lrkwz Feb 10 '12 at 15:01

1 Answer 1

up vote 0 down vote accepted

For all php-related packages use the historical repositories from old-releases.ubuntu.com for the karmic Ubuntu release to downgrade to php 5.2

I created a script solution here:
http://ubuntuforums.org/showpost.php?p=9201854&postcount=6

it adds the histroical sources to a file /etc/apt/preferences.d/php5_2 that locks all php-related packages to karmic.

your system will stil stay on the actual release (11.10) onnly php will be taken from the old release

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.