Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried loggin into an SSH server via Nautilus' "Connect to Server" feature by just leaving the password blank, but that didn't work.

How do I connect to my server using the key I have on my system?

share|improve this question
add comment

3 Answers

up vote 11 down vote accepted

Instead of entering the username in the fields below, you'll have to prepend user@ to the server address and leave both username and password blank:

enter image description here

share|improve this answer
    
I just tried this but receive 'Permission denied'. I can ssh in via the terminal, but only after I cd to the directory containing the key. Do I need to move the key somewhere else, or tell Nautilus where to find it somehow? –  Tom Brossman Sep 7 '13 at 21:27
2  
Figured it out, finally. If the above answer doesn't work for you (seems to be a common problem for EC2 users) try ssh-add path/to/keyfile and try again. That fixed it instantly for me. –  Tom Brossman Sep 17 '13 at 21:03
add comment

I had this issue when I stopped using Unity and switched to Gnome3 as my machine crawled along despite being way above spec with Unity.

Anyway, I first removed my ~/.ssh/known_hosts file to ensure it wasn't a fingerprint issue. It was not so I don't think this step was necessary.

I then tried (just for the hell of it as I'd tried everything else by now) entering my passPHRASE where it asked for my password. Lo and behold it worked.

share|improve this answer
    
Did you leave the user name field blank? –  Stefano Palazzo Feb 17 '12 at 11:54
add comment

I needed to connect to EC2 instance using .pem key + connect using normal username-password mode. I solved these requirements by including the Host aliases in ~/.ssh/config file. Example:

Host ssh_using_key
HostName abc.myawesomesite.com
User ubuntu
IdentityFile ~/.ssh/MyPrivateKey.pem
Compression yes

Host ssh_using_userpass
HostName 173.193.72.103
User root
Port 2222

Now as described above, go to File > Connect to Server in Nautilus. Example:

For SSH using Key:

Server = ssh_using_key (as in the ~/.ssh/config file)
Type = SSH
Folder = /var/www
[leave User Details BLANK.]

For SSH using Username and Password:

Server = ssh_using_userpass (as in the ~/.ssh/config file)
Port = 2222
Type = SSH
Folder = /home/www
User name = root
Password = lamepassword
Check Remember this password.

Please modify this according to your need. Hope this helps someone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.