Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using ubuntu 10.10 and today during surfing suddenly the screen turned black with this error message

(process:295): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)

What can be the reason?

share|improve this question

closed as off-topic by Braiam, BuZZ-dEE, Eric Carvalho, Warren Hill, djeikyb Dec 22 '13 at 17:41

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, BuZZ-dEE, Eric Carvalho, Warren Hill, djeikyb
If this question can be reworded to fit the rules in the help center, please edit the question.

From personal experience this error can be totally unrelated to the actual problem. I used to see it when I had more than one monitor plugged in and tried to use the Nouveau driver (a bug that has long since been fixed). This message is just a warning from another boot process. – Oli Oct 29 '10 at 14:44
any advice how can i determine the reason of this error? – fmowrg Oct 29 '10 at 15:52
I have to install my whole system again for this bug. – user Apr 17 '11 at 17:27
This bug was solved – Braiam Dec 21 '13 at 15:49
This question is from 2010. – guntbert Dec 21 '13 at 20:48

The error messages is specifically coming from plymouth; there's a fix being tested as described at . I'm assuming what's happened is that X has crashed and the message was displayed earlier in the boot process and was left on the display when X crashed.

share|improve this answer

This warning message is related to a warning during booting, and happens for everyone from time to time. It, in itself, has nothing to do with the problem with your Desktop session disappearing. As mentioned in the other answers, try using Alt-F7 or Alt-F8 to see if the console switched accidentally. (Alt-F1 through Alt-F6 are text consoles, and Alt-F7 and above are the consoles traditionally used for your Desktop sessions.)

share|improve this answer
Yeah, I have tried this when I faced this problem but in vein. – user Apr 17 '11 at 17:28

You may press accidentally Ctrl-Alt-F8..F12 key while surfing? If yes, you switch to debug console. Message itself is harmless, I see it on my notebook every startup. Next time it appears, try Ctrl-Alt-F7 to return to your X session.

share|improve this answer
Hi Extender, no, i didn't press a key. Thanks for advice. Thanks for the Ctrl-Alt-F7 Tip will try it when it happens again. – fmowrg Oct 29 '10 at 16:56
Maybe X crashed. Usually in that case you returned to GDM, but...Ctrl-Alt-F7 or F8 should help. – Extender Oct 30 '10 at 7:18

As others have said, the message you quote is probably irrelevant to the real problem, which is that your X server disappeared.

Check out these pages for how to localize the problem and report a bug:

Have a look in /var/log/kern.log for a message about an error in Xorg.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.