Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got a Desktop Shortcut for "Network Servers" which launch a Nautilus Network window. I don't know why this shortcut appeared in the first place. However I would like to get rid of it. Right clicking on the shortcut shows that the option "Move to Trash" is greyed, highlighting a permission problem?

This option is greyed may be because I am not considered as Root (by default in Ubuntu). However I don't know where the file is and therefore can't change its permission. Can I get rid of that shortcut in a terminal ? where is the file to remove ? Can I tell Ubuntu that I am Root to allow the Move to Trash option in the context menu ?

It looks like Desktop shortcuts management is a hell in Ubuntu 11.10 ...

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Open a terminal and type this to hide the shortcut

gsettings set org.gnome.nautilus.desktop network-icon-visible false

Your desktop should not display the icon for the Network Severs after this.

share|improve this answer
    
Unfortunately The Home Desktop is empty in Nautilus even after selecting View hidden files... –  Antonio Feb 8 '12 at 13:20
    
Whatever. Nautilus does not show any files in ~/Desktop even as stated earlier after selecting View Hidden Files. Opening Nautilus as root as suggested doesn't change anything whatsoever. Hence your solution does not work. I would like to know where this shortcut is placed in the /... tree in order to attempt a removal. Obviously it is not placed in Home Desktop. –  Antonio Feb 8 '12 at 14:30
    
There you go, anything else add it to your question. –  Bruno Pereira Feb 8 '12 at 14:39

Well, I managed after 2 hours to find a solution. :) I was prevented for 8 hours to post it.

  1. Install GNOME Tweak Tool also called Advanced Settings in the Dash from Ubuntu Software Center.

  2. Launch Advanced Settings from the Dash.

  3. Select Desktop and just Turn Off Network Servers visible on the Desktop.

  4. That's it. No more Launcher for Network Servers on my Unity Desktop.

I still don't know how this Desktop Launcher/Shorcut was activated on my Ubuntu 11.10.

Also, the command line solution gsettings ... does work as well. As it is too modifying the settings of the gnome.

Another GUI solution is to use dconf Editor, navigating to orggnomenautilusdesktop and to uncheck the network-icon-visible parameter.

share|improve this answer
    
did bruno's command work for you? It should have worked - it sounds very similar to yours. Please tick one of the answers to close this question. –  fossfreedom Feb 8 '12 at 20:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.