Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

When I play a movie on VLC the screen turns off after 10 minutes. I used to run Ubuntu and this didn't happen there.

share|improve this question

6 Answers 6

up vote 5 down vote accepted

There are couple of settings that you should check in VLC:
1) Tools --> Preferences --> Show All --> Video --> Disable screensaver
2) Tools --> Preferences --> Show All --> Advanced --> Inhibit the power management daemon during playback
If both of this options are checked, you could try a simple wrapper script which disables the monitor modes that will power down, standby or blank the screen prior to calling VLC:


#Disable modes
/usr/bin/xset -dpms &
/usr/bin/xset s off &

#Open VLC
/usr/bin/vlc "$@"

#Re-enable modes
/usr/bin/xset dpms
/usr/bin/xset s on
share|improve this answer
Both of the options were already checked. – sashoalm Feb 8 '12 at 11:36
so, you could try a wrapper script – Denis Feb 8 '12 at 14:17
Thanks, the wrapper script worked. – sashoalm Feb 9 '12 at 21:59
How to use the script? – Benjamin Mar 10 '13 at 14:13

For me the solution was to access System Settings as root by pressing Alt+F2 to open the run dialog at the top of the screen and run

kdesudo systemsettings

then go to 'Display and Monitor' to get to the 'Screen Saver' selection screen and uncheck the checkbox next to 'Automatically start after:', then click 'Apply'. For some reason it seems that the screen saver setting is active on the root account in various versions of Kubuntu (probably in Ubuntu as well since I've seen posts for Ubuntu users experiencing this problem too). Doing this worked for me after first trying the suggested options of disabling Display Power Management and disabling the Screen Saver on my user account. I have not tested to see if the problem returns when those items are re-enabled but as I indicated with all of those items disabled I no longer have a problem with the screen going blank while watching videos with VLC.

share|improve this answer

Have you tried to disable the "Screen Energy Saving" from the Power Management ?

System Settings > (Hardware) Power Management > Power Profiles

enter image description here

A bit older:

share|improve this answer
I unchecked "Screen Energy Saving" and the monitor still turns off after 10 min. I also tried to set it to 360 min and it still turns of after 10 minutes. I did the changes on the performance profile, and this is the profile that's currently selected because my laptop is plugged. It's as if the option is ignored. I'll try using 'xset -dpms' from the link you gave. – sashoalm Feb 8 '12 at 11:43

There is a separate setting in system/settings/display-monitor that is independent from power management settings. Just go there and disable screen saver. This will take care of your problem.

share|improve this answer

It may also help starts vlc with the "--inhibit" option. You can put that option in the VLC startup line editing the KickOff launcher menu: /usr/bin/vlc --inhibit %U that works on Debian Wheezy 7.8.0 vlc version 2.0.6 Twoflower (2.0.6-0-gbe9623c)

share|improve this answer

You could install tool like Caffeine:


Caffeine is a system applet that allows the user to temporarily inhibit both the screensaver and the sleep power saving mode, simply by clicking on it.

This could be useful for example when watching long flash videos or playing certain full screen games that don't inhibit the screensaver by themselves. Caffeine can be set to automatically activate when any user specified application is running.

More info at:

Installation steps:

sudo add-apt-repository ppa:caffeine-developers/ppa
sudo apt-get update
sudo apt-get install caffeine
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.