Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my server I am getting following issue. sudo apt-get update work successfully but sudo apt-get upgrade fails with following error. Please help me to solve this issue.

administrator@myserver:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
  firefox linux-headers-server linux-image-server linux-server
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
21 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up shared-mime-info (0.71-1ubuntu2) ...
/var/lib/dpkg/info/shared-mime-info.postinst: line 13: 17650 Segmentation fault      update-mime-database.real /usr/share/mime
dpkg: error processing shared-mime-info (--configure):
 subprocess installed post-installation script returned error exit status 139
dpkg: dependency problems prevent configuration of libgtk2.0-0:
 libgtk2.0-0 depends on shared-mime-info; however:
  Package shared-mime-info is not configured yet.
dpkg: error processing libgtk2.0-0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser:
 chromium-browser depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing chromium-browser (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-codecs-ffmpeg:
 chromium-codecs-ffmpeg depends on chromium-browser (>= 4.0.203.0~); however:
  Package chromium-browser is not configured yet.
dpkg: error processing chromium-codecs-ffmpeg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser-l10n:
 chromium-browser-l10n depends on chromium-browser (= 16.0.912.77~r118311-0ubuntu0.10.04.1)No apport report written because the error message indicates its a followup error from a previous failure.
             No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                                       No apport report written because MaxReports is reached already
                                                                                                                                                                                     No apport report written because MaxReports is reached already
                                                           No apport report written because MaxReports is reached already
                                                                                                                         No apport report written because MaxReports is reached already
                                                                                                                                                                                       No apport report written because MaxReports is reached already
                                                             No apport report written because MaxReports is reached already
                                                                                                                           No apport report written because MaxReports is reached already
 No apport report written because MaxReports is reached already
                                                               No apport report written because MaxReports is reached already
                                                                                                                             No apport report written because MaxReports is reached already
   No apport report written because MaxReports is reached already
                                                                 ; however:
  Package chromium-browser is not configured yet.
dpkg: error processing chromium-browser-l10n (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libevdocument2:
 libevdocument2 depends on libgtk2.0-0 (>= 2.14.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libevdocument2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libevview2:
 libevview2 depends on libevdocument2 (>= 2.29.5); however:
  Package libevdocument2 is not configured yet.
 libevview2 depends on libgtk2.0-0 (>= 2.20.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libevview2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evince:
 evince depends on libevdocument2 (>= 2.29.5); however:
  Package libevdocument2 is not configured yet.
 evince depends on libevview2 (>= 2.29.5)No apport report written because MaxReports is reached already
                                                                                                       ; however:
  Package libevview2 is not configured yet.
 evince depends on libgtk2.0-0 (>= 2.16.0); however:
  Package libgtk2.0-0 is not configured yet.
 evince depends on shared-mime-info; however:
  Package shared-mime-info is not configured yet.
dpkg: error processing evince (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gcalctool:
 gcalctool depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gcalctool (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgdict-1.0-6:
 libgdict-1.0-6 depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgdict-1.0-6 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnome-utils:
 gnome-utils depends on libgdict-1.0-6 (>= 2.23.90); however:
  Package libgdict-1.0-6 is not configured yet.
 gnome-utils depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gnome-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gtk2-engines-pixbuf:
 gtk2-engines-pixbuf depends on gtk2.0-binver-2.10.0; however:
  Package gtk2.0-binver-2.10.0 is not installed.
  Package libgtk2.0-0 which provides gtk2.0-binver-2.10.0 is not configured yet.
 gtk2-engines-pixbuf depends on libgtk2.0-0 (= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing gtk2-engines-pixbuf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgail18:
 libgail18 depends on libgtk2.0-0 (= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgail18 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2.0-bin:
 libgtk2.0-bin depends on libgtk2.0-0 (>= 2.20.1-0ubuntu2.1); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing libgtk2.0-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pidgin:
 pidgin depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing pidgin (--configure):
 dependency problems - leaving unconfigured
Setting up update-manager (1:0.134.11.1) ...
dpkg: error processing update-manager (--configure):
 subprocess installed post-installation script returned error exit status 245
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on libgtk2.0-0 (>= 2.14.0); however:
  Package libgtk2.0-0 is not configured yet.
 update-notifier depends on update-manager; however:
  Package update-manager is not configured yet.
dpkg: error processing update-notifier (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of xulrunner-1.9.2:
 xulrunner-1.9.2 depends on libgtk2.0-0 (>= 2.18.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing xulrunner-1.9.2 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of icedtea6-plugin:
 icedtea6-plugin depends on xulrunner-1.9.2; however:
  Package xulrunner-1.9.2 is not configured yet.
 icedtea6-plugin depends on libgtk2.0-0 (>= 2.8.0); however:
  Package libgtk2.0-0 is not configured yet.
dpkg: error processing icedtea6-plugin (--configure):
 dependency problems - leaving unconfigured
Setting up libgweather-common (2.30.0-0ubuntu1.1) ...
No apport report written because MaxReports is reached already
                                                              dpkg: error processing libgweather-common (--configure):
 subprocess installed post-installation script returned error exit status 245
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of libgweather1:
 libgweather1 depends on libgtk2.0-0 (>= 2.11.0); however:
  Package libgtk2.0-0 is not configured yet.
 libgweather1 depends on libgweather-common (>= 2.24.0); however:
  Package libgweather-common is not configured yet.
dpkg: error processing libgweather1 (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 shared-mime-info
 libgtk2.0-0
 chromium-browser
 chromium-codecs-ffmpeg
 chromium-browser-l10n
 libevdocument2
 libevview2
 evince
 gcalctool
 libgdict-1.0-6
 gnome-utils
 gtk2-engines-pixbuf
 libgail18
 libgtk2.0-bin
 pidgin
 update-manager
 update-notifier
 xulrunner-1.9.2
 icedtea6-plugin
 libgweather-common
 libgweather1
E: Sub-process /usr/bin/dpkg returned an error code (1)
administrator@myserver:~$ 

Thanks, Avin

share|improve this question
    
Your /var/lib/dpkg/info/shared-mime-info.postinst might be corrupted. Can you post it's contents? –  Richard Ayotte Feb 13 '12 at 20:07

3 Answers 3

If the "dist-upgrade" solution doesn't work, try a forced reinstall of the package shared-mime-info:

sudo apt-get update
sudo dpkg -P --force-all shared-mime-info
sudo apt-get install shared-mime-info
sudo apt-get -f install
sudo apt-get dist-upgrade
  • If it fails again, I need the full output of the above commands. If it's too big, use http://www.pastebin.com and share the link here.
  • I also need the output of:

    apt-cache policy shared-mime-info
    sudo gdb update-mime-database.real -ex 'r /usr/share/mime'
    

Something tells me you suffer from this bug: https://bugs.launchpad.net/ubuntu/+source/libxml2/+bug/759525

share|improve this answer
    
Thanks for reply... Please Check output on pastebin pastebin.com/HNEnaedU –  Avin Tokade Feb 9 '12 at 12:14
    
Try removing the cache: sudo rm -fv /usr/share/mime/mime.cache ~/.local/share/mime/mime.cache; sudo update-mime-database /usr/share/mime - Do you get segmentation fault again? –  medigeek Feb 9 '12 at 13:42
    
Yes I am getting Segmentation fault error administrator@myserver:~$ sudo update-mime-database /usr/share/mime [sudo] password for administrator: Segmentation fault –  Avin Tokade Feb 13 '12 at 11:00
    
Try sudo gdb update-mime-database.real -ex 'r /usr/share/mime' - paste the output at www.pastebin.com again. I'll start a bounty for this question. –  medigeek Feb 13 '12 at 14:28

Try doing sudo apt-get update && sudo apt-get dist-upgrade if this show errors still open up synaptic > edit > fix broken packages reload and mark all upgrades.

share|improve this answer
    
Not worked..Please check commands output pastebin.com/HNEnaed –  Avin Tokade Feb 9 '12 at 12:16

This problem looks remarkably similar to this StackOverflow Question in that there was a segmentation fault for the same package shared-mime-info

The solution was buried in the comments prior to being redited back into the question (!) - download the maverick libxml2 package and install this prior to running:

sudo apt-get update && sudo apt-get upgrade

Download the .deb file appropriate to your architecture (32bit is i386 and 64bt is amd64)

Install the package via the syntax:

sudo dpkg -i [foo].deb

where [foo] is the package file name that was downloaded.

for example:

sudo dkpg -i libxml2_2.7.7.dfsg-4ubuntu0.3_i386.deb
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.