Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 10.10 dual booting with Windows 7. I have a couple of games on the Windows partition, some of which can be run with Wine. The problem is that I can't turn on the executable bit on files from mounted drives. When I go to properties and try to toggle it, it turns back off. I always need to copy said programs to the Ubuntu filesystem, which is annoying. Does anyone know how to solve this?


share|improve this question
Why do the .exe files need to be executable? They're not being executed, wine is being executed and is loading them. (Just like a Python script doesn't need to be executable if you write python or shell: sh – Oli Oct 29 '10 at 13:13
@Oli: The exe files are being executed. Wine just provides the OS emulation layer needed to execute the Windows program. – Kees Cook Oct 29 '10 at 19:45
My .exe files are associated with the wine binary. None are themselves execuable. – Oli Oct 29 '10 at 20:43

Have a bug report... (always a good place to start investigating workarounds)

share|improve this answer

Use the user mapping feature of ntfs-3g; details are in man ntfs-3g (search, using /, for "^user mapping").

Run the ntfs-3g.usermap tool with the Windows partition, which must be unmounted:

$ sudo ntfs-3g.usermap /dev/sda1  # sda1 may be different for you

It creates a "UserMapping" file in the current directory, move it to your NTFS partition (after mounting):

# you may need sudo for these commands
$ mkdir /mount/your-fs-name/.NTFS-3G
$ mv UserMapping /mount/your-fs-name/.NTFS-3G/

There is also a tutorial on user mapping.

share|improve this answer

Add exec to mount options, just be aware that this will set every file as executable (in my understanding). However this worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.