Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Alright, 3 machines running, two using Ubuntu 11.10 and one on Mac OS X.

On the two Ubuntu machines, both have samba installed and configured on the same workgroup, "HOME".

On machine 1, I can see all networked machines. On machine 2, I can only see the Mac OS X machine. It doesn't show the other Ubuntu machine.

What am I missing on machine 2 to see all networked computers?

Any suggestions are welcome. I'm pretty much stumped.

share|improve this question
    
To follow up on some observations, if I go to Network and press Ctrl + L and type in the following: smb://192.168.1.203, I can connect to machine 1. But when clicking on the homes folder, it says unable to mount location. –  Muhnamana Feb 8 '12 at 1:54
    
Can you add the smb.conf files for each pc? –  balloons Feb 17 '12 at 21:31
    
Sure, is there any easy way of posting it? The config file is rather large, with alot of stuff commented out, you want all of it? –  Muhnamana Feb 20 '12 at 18:41
    
I'm just wondering how you configured the workgroup, etc. Try comparing the smb.conf files between machine 1 and machine 2. It may reveal the issue. –  balloons Feb 21 '12 at 20:50
    
Well the workgroup on both configs are set to the same thing. Unless there are other options I should include though. –  Muhnamana Feb 21 '12 at 20:53
show 7 more comments

3 Answers 3

up vote 2 down vote accepted

From the machine that is not visible, try doing the Ctrl+L then smb://localhost. You can connect to itself.

Also, make sure that the smb service is running on the machine that you can't see.

It might also be worth seeing if you have a firewall issue, turn off the firewalls on your machines to see if there is a difference.

share|improve this answer
add comment

For Samba/CIFS shares to be discoverable for all clients it is common that one of the servers acts as a WINS server. However if both are trying to be the master it might cause this kind of behaviour.

Also iptables must be off or you should allow: 137/UDP 138/UDP 139/UDP 445/TCP

These are the Samba/CIFS ports.

Kind regards,
Jochen

share|improve this answer
add comment

I added these lines:

os level = 99
wins support = yes
name resolve order = wins lmhosts hosts bcast
domain master = yes
preferred master = yes

to my global samba configuration all the computers in my network popped right up in windows network.

found the info here:

http://whereofwecannotspeak.wordpress.com/2007/10/24/samba-as-a-wins-server-in-a-windows-peer-network/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.