Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A while ago updates stopped working. Now, when running apt-get, I get the following error:

Errors were encountered while processing:
libgl1-mesa-glx
libglu1-mesa
E: Sub-process /usr/bin/dpkg returned an error code (1)

EDIT: output http://pastebin.com/xcKLrFgV

Also, running Ubuntu 11.04

share|improve this question
1  
can you pastebin.com the entire trace of sudo apt-get update && sudo apt-get upgrade as well as cat /etc/apt/sources.list - thanks. –  fossfreedom Feb 7 '12 at 20:41
    
It would help to see the results requested by fossfreedom. You could try sudo dpkg --configure -a –  Jeremy Jared Feb 7 '12 at 21:09
    
sudo apt-get update && sudo apt-get upgrade as well as cat /etc/apt/sources.list output added. –  B Seven Feb 7 '12 at 23:17
    
Looks like the issue is with a segmentation fault in the package, or within apt. Does this happen with any other packages? –  Thomas W. Feb 7 '12 at 23:51
    
Have you tried to install libgl1-mesa-glx before installing libglu1-mesa? Somethink like: sudo apt-get install libgl1-mesa-glx && sudo apt-get install libglu1-mesa –  desgua Feb 8 '12 at 0:02

1 Answer 1

up vote 0 down vote accepted

After spending hours and hours trying to fix it and Googling, I reinstalled the OS off the installation CD I burned. I think that took only 15 minutes.

So, the lesson is to keep all you data on a separate partition. I probably don't need any updates anyway because 11.04 works fine the way it is. The entire OS only uses 4GB, so a 64GB SSD with 2 partitions works great.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.