Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My Sony Vaio laptop is connected to an external Samsung monitor and my nVidia driver is configured in TwinView mode. Everything is OK with this, however, I can not adjust my displays individually so at the moment my external display is a little bit darker which disturbs me a lot. I tried the Separate X Screen mode but after restart, my laptop display was white with a black x sign mouse pointer and the external display normal desktop. Is it a bug or something I missed? The idea is that using Separate X Screen mode, I could adjust my displays individually.

I would really appreciate someone would guide me out of this situation.

Thanx in adv..

share|improve this question
add comment

2 Answers 2

The problem is discussed in the forum: http://ubuntuforums.org/showthread.php?t=1972628&page=2 There's also a launchpad bug: https://bugs.launchpad.net/bugs/1002641 Vote for it to give it higher priority

share|improve this answer
    
Bug "priorities" are based on importance and upstream decisions. The number of people affected and the heat of the bug have no impact on how high a priority gets. –  Thomas W. Jun 7 '12 at 14:01
add comment

This seems similar to (if not the same as) the problem I was having: How are separate x screens supposed to work (probable problem)

The white screen is, apparently, caused by nautilus (which can be seen by running killall nautilus from the terminal). The following page also describes this problem and both a link to a patch that should fix the problem, and a link to a page that tells how to apply that patch: http://ubuntuforums.org/showthread.php?t=1865113

However, that only fixes the white background problem. To get rid of the x cursor and be able to interact with the laptop display, you will need to either,

  1. Download, install, and use Gnome-Classic. I cannot remember what I did to download and install Gnome-Classic, but I did some searching and I think the following command (run from the terminal) might be what does it: sudo apt-get install gnome-panel. To use Gnome-Classic, simply click on the gear icon (located near the password prompt) in the login screen and choose it from the list (and then login).
    This should allow you to interact with both displays. However, on my computer, when using separate x screens, it removed the toolbar in the first display (not really a problem if you do not mind using the terminal) and, if my first right-click was in the second display, it not only failed, but prevented me from accomplishing further right-clicks in either display.
  2. Download and install Xfce: sudo apt-get install xfce4. You should then be able to use it by selecting it from the login screen (by clicking on the gear by the password prompt). If it's not in the list, though, then check the answer given to me in the first link I posted.
    This is (in my opinion) the better option, as (for me) it ran without error (as far as I could see). Unless you do not wish to use a different desktop manager, then the first option is usable (however, buggy).
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.