Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my Ubuntu machine, I have two keymaps (US Dvorak and US QWERTY). Is there a way to change what they show up as in the Indicator Applet's layout switcher? e.g. DVK/QWR instead of USA/USA2

amit ron-

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Check this post http://ubuntuforums.org/showthread.php?p=3507927

share|improve this answer
1  
Sort of works, but file was moved to /usr/share/X11/xkb/rules in Maverick, it seems. –  Amit Ron Nov 20 '10 at 13:54

Admittedly, this is a hack.

I use the flags option in gconf-editor. The flags merely represent each keyboard layout as the two letter designation rather than national flag images. Currently, doing this causes all USA layouts to be represented with an image that has the letters "US".

I worked around this by using the Canadian keyboard layout as my Qwerty layout and USA-Dvorak as my Dvorak layout. I then renamed the "US" icon ca.svg and created a new "DV" icon and named it us.svg. The indicator now shows the proper layout.

The only problem I see is that when hovering, the tool-tip says "Canada English" when set to "US"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.