Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install squid using command

sudo apt-get install squid

but I am getting following error --

betgbs@proxy-server:~$ sudo apt-get install squid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package squid

I also tried to install apache2 and many other softwares but getting same error. Installation is done properly and system is working fine. Please help me out to install squid 3.1.19 on my Ubuntu system. Thank you

share|improve this question

1 Answer 1

Two issues:

  1. It sounds like your package lists are missing a fair number of packages that should be there. This might be a temporary problem that you can fix by running sudo apt-get update (or clicking the Check button in Update Manager), or it might indicate that your package sources are not configured correctly. If it is a problem with package sources, I would suggest picking Settings... from Update Manager and checking the Ubuntu Software and Updates tabs.

  2. The squid package contains Squid 2.x. If you want to install Squid 3.x, install the squid3 package instead. If you're running Ubuntu 11.10, this will give you version 3.1.14.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.