Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a couple of USB thumbdrives and some SDcards. All of my flash storage devices have the same problem, in 11.04 Ubuntu it looks like I can delete from, save to, even format the devices, but as soon as I unmount them and then look at them in another system or put them back on the Ubuntu system then the old files reappear and the new ones are nowhere to be found.

This includes using Disk Utility to format the drives. (???)

Anybody have a clue what's wrong with my install? The optical drive (DVD+R) is working fine.

This is all quite entertaining, but I need to be able to use my sdcards.

share|improve this question
    
Do you have any luck writing to these drives on another system? Do you have any other thumbdrives or SD cards that you can successfully write to? –  James Henstridge Feb 7 '12 at 8:03
    
The drives work fine on my Windows7 machine. My Ubuntu box can read, but not write to, any of the devices. (Though it thinks it can, as described.) –  Hydrangea Feb 7 '12 at 15:38
    
Hmmm - makes me think of a strange cacheing issue where the cache just isn't being written to the drive. Not sure how to check that though. –  Rory Alsop Apr 22 '12 at 16:47
    
Disk Utility (& Nautilus ??) has an option to do a "Safe Removal" of a USB attached drive. Have you tried that? (Not a solution, but if it works perhaps a temp workaround?) –  irrational John Apr 24 '12 at 6:53
    
I tried safe removal, no happy. Upgrading to 12.04 fixed it though. :) –  Hydrangea May 5 '12 at 17:40

2 Answers 2

This is a caching issue with the kernel's file system driver. I've seen issues like this crop up before and it's almost certainly that. You need to report a bug and help a developer to discover what is wrong/special with your system in order to get a fix.

https://help.ubuntu.com/community/ReportingBugs

For now, check if you can write to the usb sticks using the Ubuntu LiveCD. Determine what would happen if you were to do a fresh install and then do a fresh install if you need to.

share|improve this answer
    
The LiveCD worked fine, but a fresh install (on a different partition of the same drive) didn't. Upgrading to 12.04 did fix the problem though, so whatever it was it's gone now. –  Hydrangea May 5 '12 at 17:41

I had some issue like this, it worked after unmounting the partition (not the USB Stick) in the Disk Utility. After doing that, I was able to format.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.