Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to upgrate mysql 5.1 to version 5.5 Since official ubuntu repositories do not provide 5.5, I've decided to go with Dotdeb repository.

When I've updated the package information and typed in sudo apt-get install mysql-server it removed my mysql 5.1 but does not want to install 5.5, giving this error:

dpkg: error processing /var/cache/apt/archives/mysql-client-5.5_5.5.19-1~dotdeb.1_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/mysql', which is also in package mysql-client-core-5.1 5.1.54-1ubuntu4

Do you have any ideas how I can fix this?

share|improve this question
add comment

1 Answer

Hm, I'm partly guessing here, but it looks like Ubuntu have split some of mysql-client into a mysql-client-core package, which doesn't exist on Debian. So possibly the Dotdeb package dependencies/conflicts don't know about the mysql-client-core package and it hasn't removed it.

You could try

sudo apt-get remove mysql-client-core-5.1

and try again. The files that you remove with this command should be replaced by the new mysql-client you're about to install (mysql-server will depend on it and install it automatically)

Obviously, tread carefully, if the command above suddenly wants to remove 200 other packages, don't do it, and report back here with more info about the results (edit your original question).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.