Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I do not want any Java runtime environments installed on my system. I have installed all the software and applications I want installed on my system. Yet I keep finding additional stuff gets installed when automatic updates update.

I have Main (security and recommended) and Universe updates activated. Despite the fact that I have repeatedly disabled Restricted and Multiverse, they somehow keep getting reactivated. That is, when I got to Update manager > Settings they have gotten activated again. Is there a way to permanently disable Restricted and Multiverse?

What do I need to do to tell Ubuntu to only accept updates for already installed stuff and to NOT install anything new? Is there a way I can specifically blacklist JAVA from ever being installed?

I'm assuming this is a MASSIVE bug that exists in 11.10 and hopefully 12.04 will fix it. But what can I do in the meantime?

share|improve this question

1 Answer 1

Welcome to Ask Ubuntu! Yes, I'm assuming that this is a bug too but it's probably not Ubuntu's fault. This is most likely some 3rd party program asking for java becuase it depends on it. You can sit around and hope it will be fixed in Ubuntu 12.04, or you can file a bug report saying everything you know about the problem on launchpad.net. This makes the chances of the bug getting fixed go up dramatically. In the meantime, uncheck the box for the update in update manager like this: screenshot of update manager with box left unchecked

This will prevent the update from being installed. Hope that helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.