Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble with Ubuntu 11.10. It has to do with nomodeset. After I boot into Ubuntu, it goes to a purple screen for about 10 seconds and then goes blank. After that nothing happens. I've read other people's questions about this and I know it has to do with enabling nomodeset.

This worked for me when I was using the LiveCD mode, but now Ubuntu is permanently installed as a dual-boot system. Going into recovery mode doesn't work, pressing e in the boot loader and writing nomodeset after quiet splash doesn't work either. Holding Shift any time it's booting doesn't work. I don't know what to do anymore.

I have an HP Pavilion dv6 laptop with an AMD A6-3400M CPU, and my GPU is an AMD Radeon HD 6520G. I've never worked with Linux before so taking me through this step-by-step would be great. Thanks!

share|improve this question
add comment

2 Answers

Press e when booting and type radeon.nomodeset=0.

I suppose this will help you boot.

share|improve this answer
add comment

I found this link that may help you. It explains close to the bottom of the page how to temporilaly enable nomodeset, then when Ubuntu finally loads how to perminatly set the option, along with how to enabling the live cd, the document was designed for 10.10, but the ubuntu installed os commands should work just the same

http://ubuntuforums.org/showthread.php?t=1613132

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.