Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.04 on my Fujitsu Siemens AMILO Pro laptop.

The system clock keeps on falling behind. I set it to the correct time, but it slows down and speeds up sporadically.

Can I fix this? If not, why is it happening?

share|improve this question

1 Answer 1

up vote 7 down vote accepted

The clock loosing time is most likely to be caused by a fault CMOS battery. You can work around it by running ntp.

You can do this easily via the clock. Click on the clock and choose the bottom option of "Time & Date Settings..."

You have to "unlock to change these settings" and enter your password.

Near the bottom, where it says "Set the time", choose "Automatically from the internet". If you haven't got ntp installed, doing this will automatically go off and install it, so you may be asked to enter your password again to perform that step.

This will keep the system clock correct, but wont update the hardware clock on the BIOS. If you want to do that, you will need to schedule a job to run hwclock command with the -w or --systohc flag.

See man hwclock for more information.

share|improve this answer
    
My clock applet seems to be set up differently... To get the panel you referenced, I had to go into System -> Preferences -> Time & Date. Thanks! –  ThatOtherPerson Feb 7 '12 at 17:19
    
Since I don't restart my computer very often, I added a cron job that runs ntp ntp.grid.amevery hour. This seems to be running perfectly. –  ThatOtherPerson Mar 24 '12 at 16:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.