Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use a VPS with Ubuntu 10.04. After I performed "apt-get upgrade", the ssh daemon stopped working and does not automatically start when I restart my server. I have only access to files (edit, create delete etc.) and no shell access. Could you please help me out with setting up SSH Daemon autostart? Thank you very much.

share|improve this question
maybe this could be handy: – maniat1k Feb 6 '12 at 14:21
What happens when you type sudo invoke-rc.d ssh start from the console of the server? – grifferz Jul 7 '12 at 10:10

Try editing /etc/init.d/rc.local and add to the bottom:

sshd &

Then restart the server.

share|improve this answer
This is definitly not the standard solution. I think it would be better to find out why the daemon does not automatically start. – lumbric Jul 7 '12 at 9:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.