Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Iam getting a problem while install media player packages. Package dependencies cannot be resolved

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.
                      Depends: libc6 (>= 2.7) but 2.13-0ubuntu13 is to be installed
                      Depends: libglib2.0-0 (>= 2.24.0) but 2.28.6-0ubuntu1 is to be installed
                      Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.22) but 0.10.32-1ubuntu5 is to be installed
                      Depends: libgstreamer0.10-0 (>= 0.10.26) but 0.10.32-3ubuntu3 is to be installed
                      Depends: liborc-0.4-0 (>= 1:0.4.10) but 1:0.4.11-2 is to be installed
                      Depends: libpostproc-extra-51 (>= 4:0.6-1~) but 4:0.6.4-1ubuntu1+medibuntu1 is to be installed
                      Depends: libswscale-extra-0 (>= 4:0.6-1~) but 4:0.6.4-1ubuntu1+medibuntu1 is to be installed
gstreamer0.10-plugins-bad: Depends: libc6 (>= 2.7) but 2.13-0ubuntu13 is to be installed
                           Depends: libcairo2 (>= 1.2.4) but 1.10.2-2ubuntu2 is to be installed
                           Depends: libcdaudio1 (>= 0.99.12p2) but 0.99.12p2-9 is to be installed
                           Depends: libdc1394-22 but it is not going to be installed
                           Depends: libdirectfb-1.2-9 but it is not going to be installed
                           Depends: libflite1 but it is not going to be installed
                           Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
                           Depends: libglib2.0-0 (>= 2.26.0) but 2.28.6-0ubuntu1 is to be installed
                           Depends: libgsm1 (>= 1.0.13) but it is not going to be installed
                           Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.32) but 0.10.32-1ubuntu5 is to be installed
                           Depends: libgstreamer0.10-0 (>= 0.10.32) but 0.10.32-3ubuntu3 is to be installed
                           Depends: libjasper1 (>= 1.900.1) but 1.900.1-7ubuntu2 is to be installed
                           Depends: libmodplug1 but it is not going to be installed
                           Depends: libmpcdec6 (>= 1:0.1~r435) but it is not going to be installed
                           Depends: libmusicbrainz4c2a (>= 2.1.5) but it is not going to be installed
                           Depends: libofa0 (>= 0.9.3) but it is not going to be installed
                           Depends: liborc-0.4-0 (>= 1:0.4.10) but 1:0.4.11-2 is to be installed
                           Depends: libpng12-0 (>= 1.2.13-4) but 1.2.44-1ubuntu3 is to be installed
                           Depends: librsvg2-2 (>= 2.26.0) but 2.32.1-0ubuntu3 is to be installed
                           Depends: librtmp0 (>= 2.3) but 2.3-2 is to be installed
                           Depends: libschroedinger-1.0-0 (>= 1.0.9) but it is not going to be installed
                           Depends: libsndfile1 (>= 1.0.20) but 1.0.23-1build1 is to be installed
                           Depends: libstdc++6 (>= 4.1.1) but 4.5.2-8ubuntu4 is to be installed
                           Depends: libvpx0 (>= 0.9.0) but it is not going to be installed
gstreamer0.10-plugins-ugly: Depends: libc6 (>= 2.7) but 2.13-0ubuntu13 is to be installed
                            Depends: libgcc1 (>= 1:4.1.1) but 1:4.5.2-8ubuntu4 is to be installed
                            Depends: libglib2.0-0 (>= 2.24.0) but 2.28.6-0ubuntu1 is to be installed
                            Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.26) but 0.10.32-1ubuntu5 is to be installed
                            Depends: libgstreamer0.10-0 (>= 0.10.26) but 0.10.32-3ubuntu3 is to be installed
                            Depends: libid3tag0 (>= 0.15.1b) but it is not going to be installed
                            Depends: libmad0 (>= 0.15.1b-3) but it is not going to be installed
                            Depends: liborc-0.4-0 (>= 1:0.4.10) but 1:0.4.11-2 is to be installed
                            Depends: libstdc++6 (>= 4.1.1) but 4.5.2-8ubuntu4 is to be installed
share|improve this question
    
Try sudo apt-get install -f –  Richard Rodriguez Feb 6 '12 at 10:34

5 Answers 5

Try this:

Open the terminal and try the following commands:

sudo dpkg --configure -a       
sudo apt-get install -f

That's how I mostly fix dependency problems. As you are using 12.04 a stable version, I think this will do the trick otherwise you can do

sudo apt-get update

to get the newest packages index and then repeat the first commands.

share|improve this answer

Go to ubuntu software center >> Edit >> Software Sources >> Download From >> Select United States After that restart your computer go to software center and type wine and install it

share|improve this answer

Goto software sources and make sure that you included all software sources

in addition include mediaubuntu repository

then

sudo apt-get update
sudo apt-get upgrade

if problem persists ,it may due to broken package list try

sudo apt-get install -f

share|improve this answer

Clean your cache and redownload the packages sudo apt-get clean sudo apt-get autoclean

Try with sudo apt-get install -f , I've been getting these errors too.

Go to ubuntu software center >> Edit >> Software Sources >> Download From >> Select United States After that restart your computer go to software center and type wine and install it

sudo apt-get update to update your package list sudo apt-get autoclean to clean up any partial packages sudo apt-get clean to clean up the apt cache sudo apt-get autoremove will clean up any unneeded dependencies

Open the terminal, copy and paste all this code:

    sudo apt-get install -f &&
    sudo apt-get clean &&
    sudo apt-get autoclean &&
    sudo apt-get autoremove &&
    sudo add-apt-repository ppa:ubuntu-wine/ppa &&
    sudo apt-get update &&
    sudo apt-get upgrade &&
    sudo apt-get install wine1.5 

IF THIS NO WORK, TRY THIS: I suggest you to do these: (most of the cases, it works)

Install aptitude with sudo apt-get install aptitude command

Try to install the package you are willing to install with command like

sudo aptitude install <package-name>

Aptitude will show you the error and present you a possible (best) solution. You will be asked to choose from 3 options with a message like

Accept this solution? [Y/n/q/?]

If you see that your desired package is not listed in the (will be) installed list, simply press n to let aptitude give you the next best solution. After several trial, (if you are lucky) you will see that your desired packages are in installable list and the packages causing the dependency problems will be showing in downgrade list. In this stage Press Y to accept the solution. The packages will be downgraded to satisfy to installation request.

I'm sorry that, I can't give you a demo run of aptitude like this, but you can check this page to see some of it's action.

If, while doing this, you can identify the broken package, this command will very forcefully remove it:

sudo dpkg --remove -force --force-remove-reinstreq packagename Replace "packagename" with the real name, of course.

share|improve this answer

Install unmet dependencies one by one. It should be install automatically but unfortunately it is not.I dont know what ubuntu developers doing, only focused on GUI.

By doing this you will able to install what you are trying to install

share|improve this answer
1  
A more suitable answer may contain exact commands needed to run. –  Amol Sale Aug 31 '12 at 7:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.